Defect #7954

IE 9 can not select issues, does not display context menu

Added by Michael Russo over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:2011-03-21
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:1.1.3
Resolution:Fixed Affected version:

Description

I'm sorry, but I don't have administrative access to the Redmine server to give its version info, so I can't give the detailed information requested from SubmittingBugs

I can verify that the same problem I'm having is present on the official Redmine.org page and demo page, though.

The problem is that, when viewing the Issues page in Internet Explorer 9, many of the UI functions don't work, such as the "select all" checkbox, clicking on (the white space of) individual issues to select them, or right-clicking to bring up a context menu.

Fortunately, these functions still work in IE Compatibility Mode, and in other browsers like Firefox 4, etc.

prototype.js (168 KB) Jean-Philippe Lang, 2011-03-23 20:38


Related issues

Duplicated by Redmine - Defect #8224: Menu does not show on IE 9 beta Closed 2011-04-25

Associated revisions

Revision 5469
Added by Jean-Philippe Lang over 6 years ago

Upgrades prototype.js to 1.7.0.0 (#7954).

Revision 5586
Added by Jean-Philippe Lang over 6 years ago

Fixes Prototypejs Form.serialize() for multiple selects (#7954).

History

#1 Updated by Jean-Philippe Lang over 6 years ago

Upgrading prototype.js that comes with Redmine to the latest release (1.7.0.0) seems to fix the problem with IE9. It's available here:
https://ajax.googleapis.com/ajax/libs/prototype/1.7.0.0/prototype.js

Feedback is welcome before committing the upgrade.

#2 Updated by Jean-Philippe Lang over 6 years ago

Prototype 1.7.0.0 breaks the issue list filters.

#3 Updated by Etienne Massip over 6 years ago

Most of the js files look to come from http://script.aculo.us/downloads, shouldn't they be all updated together ?

#4 Updated by Jean-Philippe Lang over 6 years ago

The problem on the issue list is a pure prototype 1.7 issue, not scriptaculous.
Here is the bug that breaks it: https://prototype.lighthouseapp.com/projects/8886-prototype/tickets/1180 or https://prototype.lighthouseapp.com/projects/8886-prototype/tickets/1212

#5 Updated by Etienne Massip over 6 years ago

Apply the patch ? :/

#6 Updated by Jean-Philippe Lang over 6 years ago

The patch solves the problem indeed. Patched 1.7 prototypejs is attached.
I think this fix is highly needed for 1.1.3.

#7 Updated by Jean-Philippe Lang over 6 years ago

I'm not very enthusiastic about committing a patched prototype library but I don't see any other option.
I've been using this patched 1.7 for 2 days and didn't find any issue.

#8 Updated by Etienne Massip over 6 years ago

Same, with FF4, no glitch seen.

#9 Updated by Vincent Frédérick over 6 years ago

Just wanted to add it works fine in IE10 with Redmine 1.0.3

#10 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from New to Resolved
  • Resolution set to Fixed

Prototype ugraded to 1.7.0.0 in r5469.
The patch is no longer required in trunk since the issue filters form is now submitted using a regular form (non-AJAX).

The patch should still be applied in 1.1-stable.

#11 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from Resolved to Closed

1.1-stable upgraded to the patched Prototype 1.7.0.0.

Also available in: Atom PDF