Defect #8472

Private checkbox ignored on issue creation with "Set own issues public or private" permission

Added by Alexis U. over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:2011-05-31
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Issues permissions
Target version:1.2.1
Resolution:Fixed Affected version:1.2.0

Description

When a user creates a private issue, everybody who can view issues (defined in issue tracking permissions) can see it as if it was public.

Ruby version 1.8.7 (i486-linux)
RubyGems version 1.3.5
Rack version 1.1
Rails version 2.3.11
Active Record version 2.3.11
Active Resource version 2.3.11
Action Mailer version 2.3.11
Active Support version 2.3.11

issue_visibility_combo.PNG (5.16 KB) Etienne Massip, 2011-05-31 14:17


Related issues

Duplicated by Redmine - Defect #8814: Private checkbox ignored on issue creation with "Set own ... Closed 2011-05-31

Associated revisions

Revision 5991
Added by Jean-Philippe Lang over 6 years ago

Fixed: Private flag ignored when creating an issue with set_own_issues_private permission only (#8472).

History

#1 Updated by Etienne Massip over 6 years ago

How is set your roles issue visibility ?

Did you run migrations ?

#2 Updated by Alexis U. over 6 years ago

Hi,

The Set issues public or private parameter is set to true only for the manager role.
The developer has his Set own issues public or private set to true, everybody else has it set to false.

And yes, I run a migration from the version 1.1.3

#3 Updated by Etienne Massip over 6 years ago

Sorry, I meant the "Issue visibility" combo :

#4 Updated by Alexis U. over 6 years ago

When two users have a developer role on the same project, with the 'Issues visibility' set to 'All non private issues' for that role, if developer A creates a private issue (with the status new), developer B can see it and update it.
Furthermore, an anonymous member can also see it (while his issue visibility is also set to 'All non private issues').

It behaves as if the Issue tracking > View Issues parameter was not taking into account the private/public parameter of the issue.

#5 Updated by Jean-Philippe Lang over 6 years ago

Can not reproduce this issue. Any plugin installed?

#6 Updated by Alexis U. over 6 years ago

Only one: the Redmine Theme Changer plugin.

#7 Updated by Marc Baucher over 6 years ago

I have reproduced :
  • if "Set issues public or private" is checked and "Set own issues public or private" is checked, private flag is registered at issue creation
  • if "Set issues public or private" is unchecked and "Set own issues public or private" is checked, it does not work

#8 Updated by Jean-Philippe Lang over 6 years ago

  • Subject changed from Private issue visible by everyone to Private checkbox ignored on issue creation with "Set own issues public or private permission
  • Category set to Issues permissions
  • Priority changed from Normal to High
  • Target version set to 1.2.1

Got it. Actually, the "Private" checkbox is ignored when the user creates an issue and has only the "Set own issues public or private" permission. The issue is not created as a private issue.

#9 Updated by Jean-Philippe Lang over 6 years ago

  • Subject changed from Private checkbox ignored on issue creation with "Set own issues public or private permission to Private checkbox ignored on issue creation with "Set own issues public or private" permission

#10 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from New to Resolved
  • Resolution set to Fixed

Fixed in r5991.

#11 Updated by Alexis U. over 6 years ago

Great! It works fine, thanks a lot!

#12 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from Resolved to Closed

Merged in 1.2-stable.

Also available in: Atom PDF