Defect #9724

Can't remote add new categories

Added by Philippe Lafoucrière almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Philippe Lafoucrière% Done:

0%

Category:Issues
Target version:1.3.0
Resolution:Fixed Affected version:

Description

There are 2 issues with remote add categories in issues (the (+) button next to categories when update issues):

  • If categories is empty, there's no way to add a new one
  • I have an error where name can't be blank

cat1.png (30.9 KB) Philippe Lafoucrière, 2011-12-05 12:09

cat2.png (42 KB) Philippe Lafoucrière, 2011-12-05 12:09

Associated revisions

Revision 8096
Added by Jean-Philippe Lang almost 3 years ago

Parameter changed to issue_category in r7882 (#9724).

History

#1 Updated by Philippe Lafoucrière almost 3 years ago

  • Status changed from New to Resolved

#2 Updated by Etienne Massip almost 3 years ago

  • Status changed from Resolved to New

Philippe Lafoucrière wrote:

There are 2 issues with remote add categories in issues (the (+) button next to categories when update issues):

  • If categories is empty, there's no way to add a new one

Yes, in project setting.

  • I have an error where name can't be blank

AFAIK, a category has just a name?

#3 Updated by Philippe Lafoucrière almost 3 years ago

yes, I can add them from project setting, but why would it be different for the first category ?
Also, about category name, please see :


thanks

#4 Updated by Etienne Massip almost 3 years ago

  • Status changed from New to Confirmed
  • Target version set to 1.3.0
  • Affected version (unused) set to devel

Philippe Lafoucrière wrote:

yes, I can add them from project setting, but why would it be different for the first category ?

It's a simple way to hide the Category field (or Version field) to people who don't need it.

Also, about category name, please see :


thanks

Got the same issue. What's your Redmine version?

#5 Updated by Philippe Lafoucrière almost 3 years ago

I'm using redmine devel (r8091). The problem appeared 2 weeks ago approximately.
thanks

#6 Updated by Etienne Massip almost 3 years ago

Guess it's due to r7881, guess that the error is in IssueCategoriesController#create.

Version field works fine.

#7 Updated by Jean-Philippe Lang almost 3 years ago

  • Status changed from Confirmed to Resolved
  • Resolution set to Fixed

Fixed in r8096 and merged in 1.3-stable.

#8 Updated by Jean-Philippe Lang almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF