Exporting to PDF (images not shown)

Added by G C over 2 years ago

I am trying to export PDF's with images. I have tried using the copy/paste and upload when creating an issue and specifying the file name; all seem to fail exporting the picture. Tried different formats jpg and png, with same results. I have read the forum posting from several years ago, when rmagick would be installed to help solve the issue. From Redmine install page I read that the rmagick is not necessary for 4.1.0.

Thinking maybe a I should try install rmagick and see if that makes a difference. Followed the steps on this guide:


When running gem list the rmagick is shown rmagick (4.1.1). I thought I had done the steps correctly there are only a few. In redmine's info page it still shows:

ImageMagick convert available (optional) !
ImageMagick PDF support available (optional) !

I am really new to running the redmine world. Running redmine on a Windows box. Could someone point me in the right direction?

  Redmine version                4.1.0.stable
  Ruby version                   2.6.5-p114 (2019-10-01) [x64-mingw32]
  Rails version        
  Environment                    production
  Database adapter               Mysql2
  Mailer queue                   ActiveJob::QueueAdapters::AsyncAdapter
  Mailer delivery                smtp
  Git                            1.9.4
Redmine plugins:
  redmine_issue_templates        1.0.1

Replies (1)

RE: Exporting to PDF (images not shown) - Added by Ali Hamdan about 2 years ago

What are you trying to accomplish exactly to export the images attached to an issue or your images in a wiki page or just to add a logo for ur company inside ur pdf form.
Cz redmine uses rbpdf lib that includes an image function which takes png/jpeg/gif formats u just have to manipulate the redmine export lib and add a bunch of codes and it will work.