Pagination and search not working correctly in one database

Added by Craig Hawkes almost 12 years ago

Hi

I have a redmine database which we have been using for a few months. It started from a checkout of truck, and has been updated since.

1) Pagination is not working correctly (I think this is due to the count of issues not being correct)
2) Search is also not working correctly.
3) And even the timetracking, is not reporting all the time recorded.

However, I am sure there is some problem within the database rather than this being a code issue.
I have just done a new check out of the code, created a new database and inserted issuess. The paignation and search are both working correctly (this is however a much simipler dataset?) - I think point this checkout of the code at my existing database and pagination and serach stop working.

I belive that the problem may relate to the code where it checks things are limited to projects? - I am using sub-projects if this is related?

Other info:
- Ruby - mac 1.8.6 and ruby ent 1.8.7
- Rails 2.3.4
- Linux (Ubuntu 8.04) and Mac
- Postgres 8.4
- Passenger & Webrick

- let me know if there is anything else I can supply

Any help would be greatly appreciated
Thank you

Replies (2)

RE: Pagination and search not working correctly in one database - Added by Craig Hawkes almost 12 years ago

Since this, I have ported a copy of this database over to mysql and it appears (on a quick look) to be working fine. I will investigate further.

RE: Pagination and search not working correctly in one database - Added by Craig Hawkes almost 12 years ago

Upgrading to Postgres 8.4.2 (from Postgres 8.4.0) has fixed this. See issue #4314.

(1-2/2)