redmine windows install problem

Added by Anonymous over 14 years ago


i'm a RoR n00b, and i'm trying to install Redmine on a Windows box by following the installation guide in the wiki. I'm having a weird problem and i can't find anything in google.
I have ruby 1.8.6 and RoR 2.1, and the Redmine files are in C:\redmine.

When i run 'rake db:migrate RAILS_ENV="production"'.

The output i get is this:

C:\redmine>rake --trace db:migrate RAILS_ENV="production"
(in C:/redmine)
Invoke db:migrate (first_time)
Invoke environment (first_time)
Execute environment
Execute db:migrate
1 Setup: migrating =========================================================
-- create_table("attachments", {:force=>true})
> 0.0910s
-- create_table("auth_sources", {:force=>true})
> 0.0900s
-- create_table("custom_fields", {:force=>true})
> 0.1010s
-- create_table("custom_fields_projects", {:force=>true, :id=>false})
> 0.0900s
-- create_table("custom_fields_trackers", {:force=>true, :id=>false})
> 0.0900s
-- create_table("custom_values", {:force=>true})
> 0.1010s
-- create_table("documents", {:force=>true})
> 0.0900s
-- add_index("documents", ["project_id"], {:name=>"documents_project_id"})
> 0.1910s
-- create_table("enumerations", {:force=>true})
> 0.0900s
-- create_table("issue_categories", {:force=>true})
> 0.0910s
-- add_index("issue_categories", ["project_id"], {:name=>"issue_categories_project_id"})
> 0.1710s
-- create_table("issue_histories", {:force=>true})
> 0.0900s
-- add_index("issue_histories", ["issue_id"], {:name=>"issue_histories_issue_id})
> 0.1710s
-- create_table("issue_statuses", {:force=>true})
> 0.0900s
-- create_table("issues", {:force=>true})
> 0.0910s
-- add_index("issues", ["project_id"], {:name=>"issues_project_id"})
> 0.1900s
-- create_table("members", {:force=>true})
> 0.1410s
-- create_table("news", {:force=>true})
> 0.2410s
-- add_index("news", ["project_id"], {:name=>"news_project_id"})
> 0.1810s
-- create_table("permissions", {:force=>true})
> 0.0900s
-- create_table("permissions_roles", {:force=>true, :id=>false})
> 0.0910s
-- add_index("permissions_roles", ["role_id"], {:name=>"permissions_roles_role_id"})
> 0.1700s
-- create_table("projects", {:force=>true})
> 0.1000s
-- create_table("roles", {:force=>true})
> 0.1000s
-- create_table("tokens", {:force=>true})
> 0.0910s
-- create_table("trackers", {:force=>true})
> 0.0900s
-- create_table("users", {:force=>true})
> 0.0910s
-- create_table("versions", {:force=>true})
> 0.1100s
-- add_index("versions", ["project_id"], {:name=>"versions_project_id"})
> 0.1710s
-- create_table("workflows", {:force=>true})
> 0.0900s
1 Setup: migrated (6.4260s) ================================================

2 IssueMove: migrating =====================================================
2 IssueMove: migrated (0.0500s) ============================================

3 IssueAddNote: migrating ==================================================
3 IssueAddNote: migrated (0.0610s) =========================================

Invoke db:schema:dump (first_time)
Invoke environment
Execute db:schema:dump

My problem is this: As far as i can understand there are 92 migration tasks that are supposed to be done, yet my migration ends on action 3 and i don't even get an error message. That's why when i run 'rake redmine:load_default_data RAILS_ENV="production"' i get this message:

Error: Mysql::Error: #42S22Unknown column 'roles.builtin' in 'where clause': SELECT * FROM `roles` WHERE (`roles`.`builtin` = 0) LIMIT 1
Default configuration data was not loaded.

Could this be a Redmine issue, or a RoR version issue? [The installation guide says i should have RoR 2.0.2, and I have 2.1 but i didn't think it would lead to a stupid problem like this] Or perhaps some other weird issue?

As i said i'm a RoR n00b so any suggestions or tips will be very welcome.



Replies (7)

RE: redmine windows install problem - Added by Thomas Lecavelier over 14 years ago

Try by freezing RoR 2.0.2: Rails 2.1 wasn't yet tested with redmine.

rake rails:freeze:edge TAG=rel_2-0-2

RE: redmine windows install problem - Added by Anonymous over 14 years ago


I did what you suggested. I uninstalled rails 2.1.0, installed rails 2.0.2 and I still get the exact same result during migration.

Can someone send me a dump of a redmine mysql db after the rake db:migrate RAILS_ENV="production" and rake redmine:load_default_data RAILS_ENV="production" operations? I'm not sure that will work of course but no harm in trying:)

I'm all out of ideas right now, I would appreciate any help you guys can give me.



RE: RE: redmine windows install problem - Added by Thomas Lecavelier over 14 years ago

Please, copy the result of:

ruby script/about
and give you database version.


RE: redmine windows install problem - Added by Anonymous over 14 years ago

C:\redmine>ruby script/about
About your application's environment
Ruby version 1.8.6 (i386-mswin32)
RubyGems version 0.9.4
Rails version 2.0.2
Active Record version 2.0.2
Action Pack version 2.0.2
Active Resource version 2.0.2
Action Mailer version 2.0.2
Active Support version 2.0.2
Application root C:/redmine
Environment development
Database adapter mysql

db server is 5.0.51b-community-nt

RE: redmine windows install problem - Added by Patricio Anguita over 14 years ago

We have a similar problem installing in CPANEL. After doing a lot of things, not even ruby script/about is working :)

Any way to fix redmine to work with rails 2.1.0?



RE: redmine windows install problem - Added by Anonymous over 14 years ago

i have to give this a bump, i still have no solution to this problem.

can someone at least send me a dump of a redmine database right after rake db:migrate RAILS_ENV="production" , so i can restore it and use it as my database?



RE: RE: redmine windows install problem - Added by x y over 14 years ago

I just spent a couple of days trying different things. Apparently it believes that version 3 is the correct version. I forced it with:
rake --trace environment RAILS_ENV=production db:migrate -t VERSION=92
and it worked.

A subsequent db:migrate without a version number tries to undo some changes, until it gets to change 77 which is not undoable.