Issue installing plugins from GIT

Added by Valerio Bonfatti about 12 years ago

Hi all,
sorry if i'm asking an already known issue, but i have googled a lot and i've not found a real soution.

Here the command that i'm trying to run:
ruby script/plugin --verbose install git://github.com/edavis10/redmine-bulk_time_entry_plugin.git -force

The answers is always:
Plugin not found: ["git://github.com/edavis10/redmine-bulk_time_entry_plugin.git"]
#<Errno::ENOENT: No such file or directory - /dev/null>

I tried all the possible combination with "http:" instead of "git:" and with a trailing slaah and without.
I also tried the fix proposed here for windows: http://groups.google.ca/group/rubyonrails-talk/browse_thread/thread/20cb12085cb7991e

In the meanwhile i will do:
cd vendor/plugins
git clone git://xxxxx.git

Is it fine?!?

Here some information on my system:

git --version

git version 1.7.0.2.msysgit.0

ruby -v

ruby 1.8.7 (2010-01-10 patchlevel 249) [i386-mingw32]

rails -v

Rails 2.3.5

ruby script/about

About your application's environment
Ruby version 1.8.7 (i386-mingw32)
RubyGems version 1.3.7
Rack version 1.0
Rails version 2.3.5
Active Record version 2.3.5
Active Resource version 2.3.5
Action Mailer version 2.3.5
Active Support version 2.3.5
Application root C:/RubyWorld/redmine-0.9.3
Environment production
Database adapter mysql
Database schema version 20100221100219

Thanks!!!

Replies (1)

RE: Issue installing plugins from GIT - Added by Felix Schäfer about 12 years ago

The manual approach is fine, no worries there. For some reason, script/plugin tries to access /dev/null, which is obviously invalid on win32, but as to why and how to fix it: no idea.

(1-1/1)