ProxyPass /svn ! still routed to redmine

Added by Terry Cullen almost 12 years ago

Hi guys,

Great project!

I've almost got redmine with svn integration running perfectly on windows 7. Redmine works fine but the only issue I am having is that svn requests are still being routed to redmine and not to the subversion service. If I comment out the ProxyPass lines then subversion works great. If I uncomment the ProxyPass lines and browse to https://svn.example.com.au/svn/exampleproj then I get the following error which says to me that the request has been routed to redmine.

Routing Error

No route matches "/error/HTTP_UNAUTHORIZED.html.var" with {:method=>:get}

Here is my conf:

<IfModule ssl_module>
Listen 443
<IfModule mime_module>
    AddType application/x-x509-ca-cert .crt
    AddType application/x-pkcs7-crl    .crl
</IfModule>
SSLPassPhraseDialog  builtin
SSLMutex default
<VirtualHost _default_:443>
    ServerAdmin webmaster@localhost
    DocumentRoot "F:\Ruby\apps\redmine\public" 
    ServerName support.example.com.au:443
    ServerAlias svn.example.com.au:443
    ProxyPreserveHost On
    ProxyPass /svn !
    ProxyPass / http://localhost:88/
    ProxyPassReverse / http://localhost:88/
    PerlLoadModule Apache::Redmine
    <Location /svn>
        SetHandler None
        DAV svn
        SVNParentPath "F:\Subversion" 
        Order deny,allow
        Allow from localhost 192.168.1.100
        Deny from all
        PerlAccessHandler Apache::Authn::Redmine::access_handler
        PerlAuthenHandler Apache::Authn::Redmine::authen_handler
        AuthType Basic
        AuthName "Redmine SVN Repository" 
        RedmineDSN "DBI:mysql:database=example;host=localhost" 
        RedmineDbUser "example" 
        RedmineDbPass "example" 
        Require valid-user
        Satisfy any
    </Location>
    <Location /sys>
        Order deny,allow
        Allow from 192.168.1.100
        Deny from all
    </Location>
    <Directory "F:\Ruby\apps\redmine\public">
      Options Indexes FollowSymLinks
      AllowOverride FileInfo
      Order allow,deny
      Allow from all
    </Directory>
    ErrorLog "logs/error.log" 
    <IfModule log_config_module>
        CustomLog "logs/access.log" combined
    </IfModule>
    SSLEngine on
    SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
    SSLCertificateFile "conf/ssl.crt/example.crt" 
    SSLCertificateKeyFile "conf/ssl.key/example.key" 
    <FilesMatch "\.(cgi|shtml|pl|asp|php)$">
       SSLOptions +StdEnvVars
    </FilesMatch>
    <Directory "F:/xampp/cgi-bin">
        SSLOptions +StdEnvVars
    </Directory>
    BrowserMatch ".*MSIE.*" nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0
    CustomLog "logs/ssl_request.log" "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b" 
  </VirtualHost>
</IfModule>

I'm using Redmine 1.0.2.

Does anyone know what might be the issue here?

Thanks!

Terry

Replies (3)

RE: ProxyPass /svn ! still routed to redmine - Added by Felix Schäfer almost 12 years ago

You shouldn't try to shove both the svn and the redmine host into one virtualhost. Configure a separate virtual host for svn and all should be good.

In your current configuration, I suppose the ProxyPass /svn ! will prevent apache from passing the requests to /svn to redmine (as the next Proxypass defines), and that is required if you want to keep your config in one virtualhost.

RE: ProxyPass /svn ! still routed to redmine - Added by Terry Cullen almost 12 years ago

Thanks for your reply Felix.

As I understand it, to put SVN under it's own SSL virtual host would require a second IP address. I'm running redmine on my work station behind an ADSL router so I'm not so sure how to setup a second SSL vhost without a second IP address being provisioned by my ISP.

So, in order to get it working, I've setup redmine on a non-ssl vhost and all is working great.

Thanks again,

Terry

RE: ProxyPass /svn ! still routed to redmine - Added by Felix Schäfer almost 12 years ago

Terry Cullen wrote:

As I understand it, to put SVN under it's own SSL virtual host would require a second IP address.

Yes and no: there's a new extension to the whole shebang called SNI which permits multiple SSL hosts on one IP address, but don't bother yourself with that if it works for you like it is now :-) Glad you got it working.

(1-3/3)