Virtualhost not working

Added by Jake D about 9 years ago

Hey everyone, I'm at my wits end here. I've installed redmine and it works fine on the webrick server, but I'm trying to use passenger and when I go to the domain I set up as a virtualhost in the /etc/httpd/conf/httpd.conf nothing happens. I just go to the normal site. Here's how the relavent section of the httpd.conf file looks like

#ErrorLog logs/dummy-host.example.com-error_log
#    CustomLog logs/dummy-host.example.com-access_log common
#</VirtualHost>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

LoadModule passenger_module /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.2/ext/apache2/mod_passenger.so
PassengerRoot /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.2
PassengerRuby /usr/local/bin/ruby

<VirtualHost *:80>
    ServerName redmine.mysite.com
    DocumentRoot /opt/redmine-1.0.5/public/
    <Directory /opt/redmine-1.0.5/public/>
        Allow from all
        Options -MultiViews
        AllowOverride None
    </Directory>
</VirtualHost>

Am I doing something wrong here? I've heard that the .htaccess file can somehow interfere with this, is that what is happening? Sorry if this is a very noobish question.

Replies (1)

RE: Virtualhost not working - Added by Felix Schäfer about 9 years ago

Try just removing the .htaccess and see what happens. Have a look at your apache logs too and post the relevant parts here.

(1-1/1)