500 error on update of Issue after upgrading to 1.1.0

Added by Gregory Fox over 11 years ago

When I try to update an issue, I get a 500 error. Here is my log:

ActionView::TemplateError (undefined method `emails_header' for #<Class:0x6bced93b82d8>)
on line #1 of app/views/layouts/mailer.text.plain.erb:
1: <%= Setting.emails_header %>
2: <%= yield %>
3: -- 
4: <%= Setting.emails_footer %>

    app/views/layouts/mailer.text.plain.erb:1
    app/models/mailer.rb:398:in `render_multipart'
    app/models/mailer.rb:79:in `issue_edit'
    app/models/journal_observer.rb:24:in `after_create'
    /usr/lib/ruby/1.8/observer.rb:185:in `notify_observers'
    /usr/lib/ruby/1.8/observer.rb:184:in `each'
    /usr/lib/ruby/1.8/observer.rb:184:in `notify_observers'
    app/models/journal.rb:43:in `save'
    app/models/issue.rb:848:in `create_journal'
    app/models/issue.rb:554:in `save_issue_with_child_records'
    app/models/issue.rb:536:in `save_issue_with_child_records'
    app/controllers/issues_controller.rb:169:in `update'
    /dh/passenger/lib/phusion_passenger/rack/request_handler.rb:92:in `process_request'
    /dh/passenger/lib/phusion_passenger/abstract_request_handler.rb:207:in `main_loop'
    /dh/passenger/lib/phusion_passenger/railz/application_spawner.rb:400:in `start_request_handler'
    /dh/passenger/lib/phusion_passenger/railz/application_spawner.rb:351:in `handle_spawn_application'
    /dh/passenger/lib/phusion_passenger/utils.rb:184:in `safe_fork'
    /dh/passenger/lib/phusion_passenger/railz/application_spawner.rb:349:in `handle_spawn_application'
    /dh/passenger/lib/phusion_passenger/abstract_server.rb:352:in `__send__'
    /dh/passenger/lib/phusion_passenger/abstract_server.rb:352:in `main_loop'
    /dh/passenger/lib/phusion_passenger/abstract_server.rb:196:in `start_synchronously'
    /dh/passenger/lib/phusion_passenger/abstract_server.rb:163:in `start'
    /dh/passenger/lib/phusion_passenger/railz/application_spawner.rb:209:in `start'
    /dh/passenger/lib/phusion_passenger/spawn_manager.rb:262:in `spawn_rails_application'
    /dh/passenger/lib/phusion_passenger/abstract_server_collection.rb:126:in `lookup_or_add'
    /dh/passenger/lib/phusion_passenger/spawn_manager.rb:256:in `spawn_rails_application'
    /dh/passenger/lib/phusion_passenger/abstract_server_collection.rb:80:in `synchronize'
    /dh/passenger/lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
    /dh/passenger/lib/phusion_passenger/spawn_manager.rb:255:in `spawn_rails_application'
    /dh/passenger/lib/phusion_passenger/spawn_manager.rb:154:in `spawn_application'
    /dh/passenger/lib/phusion_passenger/spawn_manager.rb:287:in `handle_spawn_application'
    /dh/passenger/lib/phusion_passenger/abstract_server.rb:352:in `__send__'
    /dh/passenger/lib/phusion_passenger/abstract_server.rb:352:in `main_loop'
    /dh/passenger/lib/phusion_passenger/abstract_server.rb:196:in `start_synchronously'

Rendering /home/agilityis/agilityhq.com/public/500.html (500 Internal Server Error)

Thanks for any help...
Greg

Replies (1)

RE: 500 error on update of Issue after upgrading to 1.1.0 - Added by Jacques Manukyan over 11 years ago

You're missing some items in your config/settings.yml file.

In it, add the following and restart redmine:

emails_header:
default: ''

(1-1/1)