Chomp Error

Added by Alteran Ancient over 13 years ago

When I run this command:
rake redmine:load_default_data RAILS_ENV="production"

I get this error:
private method `chomp!' called for nil:NilClass

What does this mean? How do I fix it?

Many Thanks.

Replies (3)

RE: Chomp Error - Added by Alteran Ancient over 13 years ago

I have an inkling, actually. It just came to me. I've been running the commands through cPanel Cron Tasks, because I don't have access to SSH. Aparrently, a "Select Language:" request is supposed to appear, but because I'm running it as a CRON, I can't respond. I tried adding "; en" to the end of the CRONned command, but that didn't work. Any ideas that don't involve SSH?

RE: Chomp Error - Added by Tomás Rinke about 12 years ago

you can edit the file path/to/redmine/lib/tasks/load_default_data.rake

on line 16

lang = STDIN.gets.chomp!

replace with

lang = 'en'

or whatever language you want

RE: Chomp Error - Added by Lowell Copeland about 12 years ago

I am not sure this is a chomp error as much as a gets error. I am using the one click install version of Ruby. When I am in the sciTE interpreter, if I type a line in the script that contain the method 'gets' the program jumps to a non working command prompt window that will not accept input.

Hence, I don't have a way to input from the keyboard any data in response to a question or command.

What am I doing wrong. I know it is not in the code I am writing, because it happens every single time I use gets, no matter what the code is.

I would appreciate nay help

thanks

Lowell Copeland

(1-3/3)