error installing redmine 1.1.2

Added by Dhaval Yoganandi over 11 years ago

Hello Guys,

I am having problem installing Redmine 1.1.2 on my web hosting server. Please help.

gem -v
1.4.2

rails -v
Rails 2.3.10

gem environment
RubyGems Environment:
- RUBYGEMS VERSION: 1.4.2
- RUBY VERSION: 1.8.7 (2009-06-12 patchlevel 174) [x86_64-linux]
- INSTALLATION DIRECTORY: /home/dhaval/ruby/gems
- RUBY EXECUTABLE: /usr/bin/ruby
- EXECUTABLE DIRECTORY: /home/dhaval/ruby/gems/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-linux
- GEM PATHS:
- /home/dhaval/ruby/gems
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- "gempath" => []
- "gem" => "--remote --gen-rdoc --run-tests"
- "gemhome" => "/home/dhaval/ruby/gems"
- "rdoc" => "--inline-source --line-numbers"
- REMOTE SOURCES:
- http://rubygems.org/

ruby script/server
/usr/lib64/ruby/site_ruby/1.8/rubygems.rb:812:in `report_activate_error': RubyGem version error: rack(1.1.0 not ~> 1.0.1) (Gem::LoadError)
from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:223:in `activate'
from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:1146:in `gem'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/actionpack/lib/action_controller.rb:34
from /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
from /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/railties/lib/commands/server.rb:2
from /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
from /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
from script/server:3

Thanks in advance.
Dhaval.

Replies (14)

RE: error installing redmine 1.1.2 - Added by Etienne Massip over 11 years ago

Your rack version is not supported ?

RE: error installing redmine 1.1.2 - Added by Dhaval Yoganandi over 11 years ago

Yes may be.. I've tried all the version. But with no luck.

RE: error installing redmine 1.1.2 - Added by Etienne Massip over 11 years ago

What's your gem list ?

RE: error installing redmine 1.1.2 - Added by Dhaval Yoganandi over 11 years ago

Here,

gem list --local

  • LOCAL GEMS ***

abstract (1.0.0)
actionmailer (3.0.5, 2.3.5)
actionpack (3.0.5, 2.3.5)
activemodel (3.0.5)
activerecord (3.0.5, 2.3.5)
activeresource (3.0.5, 2.3.5)
activesupport (3.0.5, 2.3.5)
arel (2.0.9)
builder (2.1.2)
bundler (1.0.10)
daemon_controller (0.2.6)
erubis (2.6.6)
fastthread (1.0.7)
file-tail (1.0.5)
i18n (0.4.2)
mail (2.2.15)
mime-types (1.16)
passenger (3.0.5)
polyglot (0.3.1)
rack (1.2.2)
rack-mount (0.6.13)
rack-test (0.5.7)
rails (3.0.5)
railties (3.0.5)
rake (0.8.7)
spruz (0.2.5)
thor (0.14.6)
treetop (1.4.9)
tzinfo (0.3.24)

RE: error installing redmine 1.1.2 - Added by Etienne Massip over 11 years ago

Try to :
  • stop your server
  • uninstall rack 1.2.2 : gem uninstall rack
  • install 1.0.1 : gem install rack --version=1.0.1
  • start your server

Should work then.

RE: error installing redmine 1.1.2 - Added by Dhaval Yoganandi over 11 years ago

Thanks for reply.. I've tried to install new version of rack.

gem list --local | grep rack

rack (1.0.1)
rack-mount (0.6.13)
rack-test (0.5.7)

Still ruby server script throws the same error.

ruby script/server
/usr/lib64/ruby/site_ruby/1.8/rubygems.rb:812:in `report_activate_error': RubyGem version error: rack(1.1.0 not ~> 1.0.1) (Gem::LoadError)
from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:223:in `activate'
from /usr/lib64/ruby/site_ruby/1.8/rubygems.rb:1146:in `gem'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/actionpack/lib/action_controller.rb:34
from /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
from /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
from /home/dhaval/redmine/redmine-1.1.2/vendor/rails/railties/lib/commands/server.rb:2
from /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
from /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
from script/server:3

Thanks,
Dhaval

RE: error installing redmine 1.1.2 - Added by Etienne Massip over 11 years ago

Don't you have multiple ruby environments installed (in /usr/bin/ruby and /usr/lib64/ruby) ?

Looks like your server PATH is not the same as yours.

RE: error installing redmine 1.1.2 - Added by Dhaval Yoganandi over 11 years ago

Yes.. I am trying to install on a web hosting server. It has multiple ruby environment. is there any possibility to run redmine on it?

-Dhaval.

RE: error installing redmine 1.1.2 - Added by Etienne Massip over 11 years ago

Guess you can, but you have to change your PATH to run your server's ruby environment gem to install the right rack version.

RE: error installing redmine 1.1.2 - Added by Dhaval Yoganandi over 11 years ago

I think it is hard to do that.. may be a web hosting provider not allow that.

RE: error installing redmine 1.1.2 - Added by Etienne Massip over 11 years ago

You can change it for the time of your session context before running the command.

RE: error installing redmine 1.1.2 - Added by Etienne Massip over 11 years ago

Not sure I was right with my previous statement.

Btw, why is there a rails subdir in your redmine-1.1.2/vendor dir ??

RE: error installing redmine 1.1.2 - Added by Dhaval Yoganandi over 11 years ago

well.. thanks for all the replies. Some other guy did it.

(1-14/14)