Install problems. rake generate_session_store fails

Added by Mike M. almost 9 years ago

I'm following the instructions here: https://sites.google.com/site/alensit/software-tools/redmine#TOC-Running-under-Mongrel

And getting this error when I try to do the rake generate_session_store command:

C:\redmine>rake generate_session_store
(in C:/redmine)
NOTE: SourceIndex.new(hash) is deprecated; From C:/redmine/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100:in `new'.
rake aborted!
uninitialized constant ActiveSupport::Dependencies::Mutex
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in `raw_load_rakefile'
(See full trace by running task with --trace)

C:\redmine>

I have ruby 1.8.7, redmine 1.1.2, and the rest of the versions are per his instructions. Googling for this error produces very little, but including a 3-day old question asked here. Any help would be greatly appreciated.

Thanks,
Mike

Replies (9)

RE: Install problems. rake generate_session_store fails - Added by Felix Schäfer almost 9 years ago

What version of rubygems do you have installed?

RE: Install problems. rake generate_session_store fails - Added by Michael Richards almost 9 years ago

I am facing the same issue. Ruby: 1.87, Gems: 1.7.2, Redmine: 1.1.2

One thing I did that may have been wrong was doing a 'gem install rails' with no version specification. I went back and did 'gem install rails -v=2.3.5' and 'gem install rack -v=1.0.1'

RE: Install problems. rake generate_session_store fails - Added by Felix Schäfer almost 9 years ago

You need rails 2.3.5 (except maybe on trunk) and rack 1.0.1 for sure, and I think rails 2.3.5 worked with rubygems only up to a certain version. There should be a fix in there for rubygems up to 1.6, not sure it works on 1.7. Try downgrading your rubygems to 1.6 latest or even 1.3.2 if that doesn't work.

RE: Install problems. rake generate_session_store fails - Added by Michael Richards almost 9 years ago

"RubyGems 1.3.1 or higher is required (Rails 2.3.5 will fail with RubyGems 1.5.0 and later, stick to previous versions of RubyGems)"

Oops. I am very new to this Ruby stuff. Trying to uninstall? gems 1.7.2 now.

RE: Install problems. rake generate_session_store fails - Added by Felix Schäfer almost 9 years ago

Michael Richards wrote:

Oops. I am very new to this Ruby stuff. Trying to uninstall? gems 1.7.2 now.

As I said, there is a fix in Redmine to work with rubygems 1.5 and 1.6 I believe. And you don't want to uninstall but downgrade it, try googling for "rubygems downgrade" or something.

RE: Install problems. rake generate_session_store fails - Added by Michael Richards almost 9 years ago

Now I am getting the following:

C:\redmine>rake generate_session_store
(in C:/redmine)
rake aborted!
uninitialized constant ActiveSupport::Dependencies::Mutex
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in `raw_load_rakefile'
(See full trace by running task with --trace)

C:\redmine>

C:\redmine>rake generate_session_store --trace
(in C:/redmine)
rake aborted!
uninitialized constant ActiveSupport::Dependencies::Mutex
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2503:in `const_missing'
C:/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:55
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
C:/redmine/vendor/rails/activesupport/lib/active_support.rb:56
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
C:/redmine/vendor/rails/railties/lib/tasks/misc.rake:18
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:4:in `load'
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:4
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:4:in `each'
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:4
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
C:/redmine/Rakefile:10
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in `load'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in `raw_load_rakefile'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2017:in `load_rakefile'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2016:in `load_rakefile'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2000:in `run'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
C:/Ruby187/bin/rake:19:in `load'
C:/Ruby187/bin/rake:19

C:\redmine>

RE: Install problems. rake generate_session_store fails - Added by Felix Schäfer almost 9 years ago

I'd almost suspect a problem with your install (not Redmine, but the underlying ruby/rubygems stack), but I honestly have no idea, sorry :-/

RE: Install problems. rake generate_session_store fails - Added by Michael Richards almost 9 years ago

I would like to have a chat with the person who decided to put the "Alternative to manual installation" at the bottom of the manual installation instructions...

BitNami installer... DONE.

Thanks for you help.

RE: Install problems. rake generate_session_store fails - Added by Mike M. almost 9 years ago

Thanks, Michael, for pointing that out. Downloaded Bitnami installer and giving it a go...

(1-9/9)