how to completely disable darcs in redmine 1.2.0

Added by Juan G over 11 years ago

Hi!

After upgrading to redmine 1.2.0 I can't access to my setup administracion page. I see errors in logs when redmine tries to shell out "darcs --version" (I don't have darcs installed).

I tried to disable darcs in database, SETTINGS table, NAME="enabled_scm" and updated UPDATED_ON field in that record, but it still continues to shell out that command.

How can I completely disable darcs to avoid that error? Is there another table I should update to apply that changes?

Thanks!

Replies (5)

RE: how to completely disable darcs in redmine 1.2.0 - Added by Toshi MARUYAMA over 11 years ago

I tested clean Redmine on Linux and Windows, and I can not reproduce.
What OS do you use?
Are you using plug-ins?

RE: how to completely disable darcs in redmine 1.2.0 - Added by Juan G over 11 years ago

Hi Toshi thanks for answer,

My environment is UNIX (Red Hat 5 I guess).

I don't use any plugins.

I am using jruby instead ruby, but I wanted first to discard any Redmine problem before investigating if there are some cache with JRuby.

Thanks!

RE: how to completely disable darcs in redmine 1.2.0 - Added by Juan G over 11 years ago

Toshi MARUYAMA wrote:

You can set dummy data at this line.
http://www.redmine.org/projects/redmine/repository/entry/branches/1.2-stable/lib/redmine/scm/adapters/darcs_adapter.rb#L56

I don't test on JRuby.
Please create new issue.

Create new issue in redmine? So this is a bug?

RE: how to completely disable darcs in redmine 1.2.0 - Added by Toshi MARUYAMA over 11 years ago

Juan G wrote:

Create new issue in redmine? So this is a bug?

Yes, please create new issue.

(1-5/5)