Upgrade from 1.1.2 to 1.2.0 with SVN

Added by Tim Bennen over 9 years ago

Hello all.

I have a Redmine installation with SVN checkout. Now I want to upgrade from 1.1.2 to 1.2.0.
I installed the new version of rack and rails and then I did a
svn update
I did an update, I do the migrations and some other stuff and then Redmine runs, but with version 1.1.3.6000 (6000 is the SVN revision number).
So, interesting, I get Redmine 1.1.3 running with Rails 2.3.11, but I want to have Redmine 1.2.0.

So I checked the SVN URL and I see, that it seems to be
http://redmine.rubyforge.org/svn/branches/1.1-stable
But for 1.2.0 I need to have
http://redmine.rubyforge.org/svn/branches/1.2-stable

So how can I change this so I can upgrade now from 1.1.3 to 1.2.0?

Best Regards Tim

Replies (3)

RE: Upgrade from 1.1.2 to 1.2.0 with SVN - Added by Scott Corscadden over 9 years ago

Did you get an answer on this Tim? (perhaps via other channels, as I can't see a response here). I am considering just using the svn switch command to upgrade (taking backups first and running rake/upgrades after). I tried to paste the commands I'll use into a preformatted section below, but it continually trips a "this-is-spam-rejection" filter in this instance of Redmine unfortunately. I'll let you know if it works though.

./scc

RE: Upgrade from 1.1.2 to 1.2.0 with SVN - Added by Scott Corscadden over 9 years ago

This totally worked for me. I'll try to describe the steps without tripping the $%%$# spam filter:
  • make the backups of the file system and database first
  • make a recursive copy of the redmine-1.1 root (ie, cp -r redmine-1.1 scc-redmine)
  • cd scc-redmine
  • gem install rails -v=2.3.11
  • svn switch ht tp://redmine.rubyforge.org/svn/branches/1.2-stable . (the space between "ht" and "tp" is required to avoid spam marking, I've determined)
  • rake db:migrate RAILS_ENV=production
  • apachectl graceful (or whatever)

Unbelievably, this worked the first try for me. Obviously YMMV, so make sure you know how to restore/recover (no warranty!).

RE: Upgrade from 1.1.2 to 1.2.0 with SVN - Added by Ka Yue Yeung about 9 years ago

I followed Scott's method and it works great!

I upgraded from 1.1.3 to 1.2. Also you have to upgrade rails (2.3.11) and rack (1.1.1) to a correct version (See install guide for details: http://www.redmine.org/projects/redmine/wiki/RedmineInstall).

(1-3/3)