LDAP Configuration.

Added by Jefferson Campos over 11 years ago


I am trying configure my Redmine installation to use LDAP authentication but every time I click on link "test" I got this error:

Unable to connect (Connection reset by peer - SSL_connect)

Of course, I cant login using this method or even using a other valid user from LDAP server (Ex. domain\valid_user) - I got same error.


Server Redmine:
Debian squeeze (6.0) and Redmine installed from repository via apt-get. Built in authentication works fine!

Server LDAP:
Windows 2003 with Active Directory

My data:

Host: 172.16.X.X (valid ip of LDAP server)
Port: 3268 (I think that server uses secure connection - ldaps)
LDAPS: option checked
Account: (valid account - admin of AD)
Password: ********
Base DN: (address ok - used in another place and works fine!)

On-the-fly user creation: option checked

Login: (same account - valid user and admin of AD)

Note: if option "LDAPS" was not checked, the test link works fine for me but I cant login too - got same error.

Any help is welcome!
Thanks in advance...

Replies (2)

RE: LDAP Configuration. - Added by Felix Schäfer over 11 years ago

I think there are some discussions about making Redmine work with AD, have you already tried those?

RE: LDAP Configuration. - Added by Anonymous over 11 years ago

Unfortunately I personally perceive it might be a bit hard to say not knowing your entire internal network and setup. If LDAP is working successfully in other implementations of redmine on your internal network then it may possibly be configuration. I'm not sure what an SSL_connect peer is, but what would this test link happen to be also?