Problem with installation : getting the redmine homepage but the html is escaped

Added by Régis Guyomarch about 11 years ago

Hello,

I'm trying to install redmine on ubuntu. I've followed this guide [[http://doc.ubuntu-fr.org/redmine]]. I've installed mongrel and configured apache to act as a proxy on http://127.0.0.1:3000. Everything seems fine but the redmine's homepage html I get in my browser is escaped in a pre tag. If I open 127.0.0.1:3000 directly in links, I get the same error.

Does anyone knows what's happening ?

Thanks for your help,
Régis

Replies (4)

RE: Problem with installation : getting the redmine homepage but the html is escaped - Added by Régis Guyomarch about 11 years ago

In fact, the content-type was text/plain.

add these lines to lib/mongrel/cgi.rb

 @head['cookie'] = options['cookie'] if options['cookie']
 options.delete('cookie')

just before the line
REMOVED_KEYS.each {|k| options.delete(k) }

It worked for me.

RE: Problem with installation : getting the redmine homepage but the html is escaped - Added by Alexander Bondarchuk about 11 years ago

Same problem, but in Windows. Can you give me any ideas where to fix same thing?

RE: Problem with installation : getting the redmine homepage but the html is escaped - Added by Régis Guyomarch about 11 years ago

I don't use windows, so I don't know where the files are located.

I think you should search for a file named cgi.rb on your computer and modify it as explained.

RE: Problem with installation : getting the redmine homepage but the html is escaped - Added by Alexander Bondarchuk about 11 years ago

Hi everyone!
I've solved the issue to me.
I've used the official instalation instruction, copability notes: http://www.redmine.org/projects/redmine/wiki/RedmineInstall#Compatibility-notes

More precisely, i think, it was: http://www.redmine.org/issues/7688

Good luck!

(1-4/4)