Install plugin

Added by jhony gonzalez over 11 years ago

Hello days ago that I am trying to install a plugin
and follow the tutorial for this but when the digit code rake db: migrate_plugins

It generated the following error

rake aborted!
uninitialized constant ActionView::TemplateFinder

Can you help me

Replies (7)

RE: Install plugin - Added by Eric Davis over 11 years ago

What plugin? What's your Redmine environment? (http://www.redmine.org/boards/2/topics/show/667)

Eric

RE: Install plugin - Added by jhony gonzalez over 11 years ago

in the plugin tutorial say that you must download the Redmine r1786, which then nose down as I did was download the plugin engines, and go to the root of these folders to copy r1786 said generators plugin and start creating a track steps in the tutorial when you use the command rake rake db: migrate_plugins It generated the following error

rake aborted!
uninitialized constant ActionView::TemplateFinder

I feel lost.
1 i don't know as download this version r1786
2 and with the latest version if I make all this comes out errors.

maybe if you could explain more clearly how a series of great help, because the idea is to learn to do this to develop plug-in and learn how to install the existing ones.

Thanks

RE: Install plugin - Added by Eric Davis over 11 years ago

I found this thread. What version of Rails are you running?

Eric

RE: Install plugin - Added by jhony gonzalez over 11 years ago

I have this on my pc

Ruby version 1.8.6 (i386-mswin32)
RubyGems version 1.3.0
Rails version 2.1.1
Active Record version 2.1.1
Action Pack version 2.1.1
Active Resource version 2.1.1
Action Mailer version 2.1.1
Active Support version 2.1.1
Application root C:/web/apps/test
Environment development
Database adapter mysql

as engines of which version I have installed on your computer and which should I get off as

RE: Install plugin - Added by jhony gonzalez over 11 years ago

hello
I tried to install a plugin

lo primero que hice fue corre el siguiente comando

the first thing I did was run the following command
ruby script / plugin install http://svn.rails-engines.org/engines/tags/rel_2.0.0/

all right

but the next step I do not understand
mv vendor/plugins/rel_2.0.0 vendor/plugins/engines

It presented the following error

"MV" is not recognized as an internal command
program or batch file executable.

then I still ignoring this step

I make the next step
Then, copy your plugin directory into RAILS_ROOT # () / vendor / plugins

*Timesheet plugin

and finally

rake db:migrate_plugins

it present the following error

rake aborted!
You have a nil object when you didn't expect it
You might have expected an instance of Array.
The error occurred while evaluating nil.empty?

(See full trace by running task with --trace)

and when tried to run redmine

ruby script/server

it presented the nex error

GLoc v1.1 running in development mode. Strings can be modified at runtime.
C:/web/pluginredmine2/vendor/rails/activesupport/lib/active_support/dependencies.rb:376:in `new_cons
tants_in': You have a nil object when you didn't expect it! (NoMethodError)
You might have expected an instance of Array.
The error occurred while evaluating nil.empty? from C:/web/pluginredmine2/vendor/rails/activesuppor
t/lib/active_support/dependencies.rb:202:in `load_file'
from C:/web/pluginredmine2/vendor/rails/activesupport/lib/active_support/dependencies.rb:94:
in `require_or_load'
from C:/web/pluginredmine2/vendor/rails/activesupport/lib/active_support/dependencies.rb:248
:in `load_missing_constant'
from C:/web/pluginredmine2/vendor/rails/activesupport/lib/active_support/dependencies.rb:453
:in `const_missing'
from C:/web/pluginredmine2/vendor/rails/activesupport/lib/active_support/dependencies.rb:465
:in `const_missing'
from C:/web/pluginredmine2/vendor/rails/activesupport/lib/active_support/dependencies.rb:260
:in `load_missing_constant'
from C:/web/pluginredmine2/vendor/rails/activesupport/lib/active_support/dependencies.rb:453
:in `const_missing'
from C:/web/pluginredmine2/vendor/rails/activesupport/lib/active_support/dependencies.rb:471
:in `send'
... 25 levels...
from C:/web/pluginredmine2/vendor/rails/railties/lib/commands/server.rb:39
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from script/server:3

I've become redmine fan and I want to see how the plugin please help
thanks

RE: Install plugin - Added by Eric Davis over 11 years ago

jhony gonzalez wrote:

but the next step I do not understand
mv vendor/plugins/rel_2.0.0 vendor/plugins/engines

It presented the following error

"MV" is not recognized as an internal command
program or batch file executable.

then I still ignoring this step

mv is the unix command for move. When you did the script/plugin install it created the engines directory as "rel_2.0.0" but it should be named "engines". Rename this directory and you should have engines installed.

Eric

RE: Install plugin - Added by jhony gonzalez over 11 years ago

thanks erick

it was a big step I was ignoring
maybe many other persons have the same question

simply because of the language barrier
I will publish it in Spanish maybe
can help many others

thanks

(1-7/7)