Problem installing Redmine 1.2.2

Added by Christoph S. Ackermann over 8 years ago

Hi there

I have a problem by installing Redmine 1.2.2:

rake aborted!
uninitialized constant Gem::SyckDefaultKey

Ruby 1.8.7 was installed with this howto:
http://www.xelacomp.com/blog/02-09-2011/install-ruby-187-rubygems-and-passenger-centos5-64-bit

[rails@centos01]$ ruby -v
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
[rails@centos01]$ rails -v
Rails 2.3.11

Rake = 0.8.7

[rails@centos01]$ rackup -v
Rack 1.1 (Release: 1.3)

Thanks!

Cheers
Christoph

Replies (7)

RE: Problem installing Redmine 1.2.2 - Added by Daniel Sperl over 8 years ago

Same problem here! Any ideas?

Thanks in advance!
Daniel

RE: Problem installing Redmine 1.2.2 - Added by Merijn van den Dungen over 8 years ago

I have exactly the same problem, only not on Centos but Debian, using the same 64 bit version.

Help is greatly appreciated!

RE: Problem installing Redmine 1.2.2 - Added by Daniel Sperl over 8 years ago

On my system, it helped to downgrade Ruby gems to an older version:

sudo gem update --system 1.3.7

I hope this helps for you, too!

RE: Problem installing Redmine 1.2.2 - Added by Merijn van den Dungen over 8 years ago

Merijn van den Dungen wrote:

I have exactly the same problem, only not on Centos but Debian, using the same 64 bit version. I am running a 32 bit version with the same specs on another machine which does not have this problem.

Help is greatly appreciated!

RE: Problem installing Redmine 1.2.2 - Added by Merijn van den Dungen over 8 years ago

I am having some trouble with used format here ;-)

What I wanted to say is that I do not have these problems with the 32 bit version. I am going to try the downgrade, thanks!

RE: Problem installing Redmine 1.2.2 - Added by Christoph S. Ackermann over 8 years ago

Thanks Daniel!

This hint works:

sudo gem update --system 1.3.7

Cheers Chris

RE: Problem installing Redmine 1.2.2 - Added by Leandro Guida about 8 years ago

What if I can't downgrade? (Onine hosting)

(1-7/7)