Issue with uppgrade from 1.1.0 to 1.3.0

Added by Stéphane Liabat over 8 years ago

Hi,

I have an issue with uppgrade from 1.1.0 to 1.3.0 :(

rake db:migrate RAILS_ENV=production
(in /data/http/redmine-1.3.0)
rake aborted!
undefined method `requirement' for #<Rails::GemDependency:0xb7d7b81c>

(See full trace by running task with --trace)

rake db:migrate RAILS_ENV=production --trace
(in /data/http/redmine-1.3.0)
Invoke db:migrate (first_time)
Invoke environment (first_time)
Execute environment
rake aborted!
undefined method `requirement' for #<Rails::GemDependency:0xb7d2541c>
/data/http/redmine-1.3.0/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:81:in `add_load_paths'
/data/http/redmine-1.3.0/config/../vendor/rails/railties/lib/initializer.rb:301:in `add_gem_load_paths'
/data/http/redmine-1.3.0/config/../vendor/rails/railties/lib/initializer.rb:301:in `each'
/data/http/redmine-1.3.0/config/../vendor/rails/railties/lib/initializer.rb:301:in `add_gem_load_paths'
/data/http/redmine-1.3.0/config/../vendor/rails/railties/lib/initializer.rb:132:in `process'
/data/http/redmine-1.3.0/config/../vendor/rails/railties/lib/initializer.rb:113:in `send'
/data/http/redmine-1.3.0/config/../vendor/rails/railties/lib/initializer.rb:113:in `run'
/data/http/redmine-1.3.0/config/environment.rb:24
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/data/http/redmine-1.3.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in `require'
/data/http/redmine-1.3.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in `new_constants_in'
/data/http/redmine-1.3.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in `require'
/data/http/redmine-1.3.0/vendor/rails/railties/lib/tasks/misc.rake:4
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequisites'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequisites'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in `invoke_task'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
/usr/bin/rake:19:in `load'
/usr/bin/rake:19
gem list

LOCAL GEMS ***
actionmailer (2.3.14, 2.3.11, 2.3.5)
actionpack (2.3.14, 2.3.11, 2.3.5)
activerecord (2.3.14, 2.3.11, 2.3.5)
activeresource (2.3.14, 2.3.11, 2.3.5)
activesupport (2.3.14, 2.3.11, 2.3.5)
capistrano (2.5.19)
cgi_multipart_eof_fix (2.5.0)
daemons (1.1.0)
fastthread (1.0.7)
gem_plugin (0.2.3)
highline (1.6.1)
i18n (0.4.2)
mongrel (1.1.5)
mongrel_cluster (1.0.5)
net-scp (1.0.4)
net-sftp (2.0.5)
net-ssh (2.0.24)
net-ssh-gateway (1.0.1)
rack (1.1.2, 1.0.1)
rails (2.3.14, 2.3.11, 2.3.5)
rake (0.8.7)
rdoc (2.4.2)
rubygems-update (1.3.7)

Please help.