Ruby on Rails application could not be started (1.3.3 -> 1.4.1)

Added by Joaquim Homrighausen over 10 years ago

I successfully migrated from 1.0.4 to 1.3.3 yesterday.
Today I wanted to migrate from 1.3.3 to 1.4.1 and initially all went well.
Then I changed the e-mail settings in configuration.yml, restarted Apache/Passenger/etc and was greated by this:

Error message:
Some gems may need to be installed or updated. Please run `bundle install --without development test`
(I have done that, and it yields no changes)

The last few trace hops are:

0 /home/redmine-1.4.1/config/preinitializer.rb 19 in `exit'
1 /home/redmine-1.4.1/config/preinitializer.rb 19
2 /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb 31 in `gem_original_require'
3 /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb 31 in `require'
4 /usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb 297 in `preload_application'

This is on Ubuntu 10.04.LTS

ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]

RubyGems Environment:
- RUBYGEMS VERSION: 1.3.7
- RUBY VERSION: 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]
- INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
- RUBY EXECUTABLE: /usr/bin/ruby1.8
- EXECUTABLE DIRECTORY: /usr/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-linux
- GEM PATHS:
- /usr/lib/ruby/gems/1.8
- /root/.gem/ruby/1.8
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://rubygems.org/

  • LOCAL GEMS ***

actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activeresource (2.3.14)
activesupport (2.3.14)
bundler (1.1.3)
coderay (1.0.6)
fastercsv (1.5.4)
i18n (0.6.0, 0.4.2)
mysql (2.8.1)
net-ldap (0.3.1)
pg (0.13.2)
rack (1.1.3, 1.1.1)
rails (2.3.14)
rake (0.9.2.2)
rdoc (2.4.2)
rmagick (2.13.1)
ruby-openid (2.1.8)
sqlite3 (1.3.6)
tzinfo (0.3.33)

Replies (4)

RE: Ruby on Rails application could not be started (1.3.3 -> 1.4.1) - Added by Joaquim Homrighausen over 10 years ago

RAILS_ENV=production script/about:

About your application's environment
Ruby version 1.8.7 (x86_64-linux)
RubyGems version 1.3.7
Rack version 1.1.3
Rails version 2.3.14
Active Record version 2.3.14
Active Resource version 2.3.14
Action Mailer version 2.3.14
Active Support version 2.3.14
Application root /home/redmine-1.4.1
Environment production
Database adapter mysql
Database schema version 20120301153455

RE: Ruby on Rails application could not be started (1.3.3 -> 1.4.1) - Added by Joaquim Homrighausen over 10 years ago

How weird .. changing all file permissions to 775 and 664 instead of 770 and 660 works. Why is that strange, well, because the Apache user owns everything in the Redmine directories ..

RE: Ruby on Rails application could not be started (1.3.3 -> 1.4.1) - Added by Bhavin Shah over 10 years ago

I am having the same issue.... i am getting some wierd stack trace in mongrel

activesupport-2.3.14/lib/active_support/inflector.rb:3:in `<top (required)>': iconv will be deprecated in the future, use String#encode instead.
NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
Gem.source_index called from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails/gem_dependency.rb:21.
C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/actionpack-2.3.14/lib/action_controller/mime_type.rb:80: warning: already initialized constant PDF
C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/actionpack-2.3.14/lib/action_controller/mime_type.rb:80: warning: already initialized constant PNG
C:/webserver/ruby/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find mongrel (~> 1.1.5) amongst [rake-0.9.2.2, activesupport-2.3.14, rack-1.1.3, actionpack-2.3.14, actionmailer-2.3.14, activerecord-2.3.14, activeresource-2.3.14, bundler-1.1.3, coderay-1.0.6, gem_plugin-0.2.3, i18n-0.4.2, json-1.7.0, mongrel-1.2.0.pre2, mongrel_service-0.4.0, mysql-2.8.1-x86-mingw32, mysql2-0.2.18-x86-mingw32, net-ldap-0.3.1, permutation-0.1.8, rails-2.3.14, rdoc-3.12, rmagick-2.13.1, ruby-openid-2.1.8, sdoc-0.3.16, tzinfo-0.3.33, win32-api-1.4.8-x86-mingw32, windows-api-0.4.1, windows-pr-1.2.1, win32-service-0.7.2-x86-mingw32] (Gem::LoadError)
    from C:/webserver/ruby/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:256:in `to_spec'
    from C:/webserver/ruby/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:435:in `find_by_name'
    from C:/webserver/redmine/config/initializers/mongrel.rb:1:in `<top (required)>'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:173:in `load'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:173:in `load_with_new_constant_marking'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/initializer.rb:622:in `block in load_application_initializers'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/initializer.rb:621:in `each'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/initializer.rb:621:in `load_application_initializers'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/initializer.rb:176:in `process'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/initializer.rb:113:in `run'
    from C:/webserver/redmine/config/environment.rb:21:in `<top (required)>'
    from C:/webserver/ruby/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `require'
    from C:/webserver/ruby/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `rescue in require'
    from C:/webserver/ruby/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/mongrel/rails.rb:147:in `rails'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/mongrel_rails:116:in `block (2 levels) in run'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/mongrel/configurator.rb:149:in `call'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/mongrel/configurator.rb:149:in `listener'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/mongrel_rails:102:in `block in run'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/mongrel/configurator.rb:50:in `call'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/mongrel/configurator.rb:50:in `initialize'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/mongrel_rails:86:in `new'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/mongrel_rails:86:in `run'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/mongrel/command.rb:210:in `run'
    from C:/webserver/ruby/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/mongrel_rails:282:in `<top (required)>'
    from C:/webserver/ruby/bin/mongrel_rails:23:in `load'
    from C:/webserver/ruby/bin/mongrel_rails:23:in `<main>'

I have installed 1.2.0 pre version of mongrel.. Stuck here since two days.

RE: Ruby on Rails application could not be started (1.3.3 -> 1.4.1) - Added by Bhavin Shah over 10 years ago

I am having the same problem. Any resolution?

(1-4/4)