problem when run redmine 2.0 under Thin with prefix enabled

Added by donny xie about 12 years ago

I installed redmine 2.0 successfully, but when I run it with Thin there is a strange problem

if I run it with

 thin start -e production 
everything is ok.

but when I run with

 thin start -e production --prefix=/redmine 
, all the javascripts and css files don't work, then I check the source code of pages and found those static files' path are not started with the prefix 'redmine', but the other links in the page has the 'redmine' prefix.

page's source code likes:

<script src="/javascripts/prototype.js?1337012592" type="text/javascript"></script>
<script src="/javascripts/effects.js?1337012592" type="text/javascript"></script>
<script src="/javascripts/dragdrop.js?1337012592" type="text/javascript"></script>

but some other links in the page are

<li><a href="/redmine/my/account" class="my-account">My account</a></li>
<li><a href="/redmine/logout" class="logout">Sign out</a></li>

How could this happen? and how to resolve it?