Update Problems

Added by Ansgar Helfrich over 9 years ago

Hi all,

I would like to update redmine from version 1.4 to 2.0.1.
At first I looked at:
"http://www.redmine.org/projects/redmine/wiki/RedmineInstall"
and learned that I need "Rails 3.2.3"
So I tried to update ruby:
1.) I installed 'rvm'. As a result I have the "rvm-command" I can work with.
@
  1. rvm -v

rvm 1.14.1 (stable) by Wayne E. Seguin <>, Michal Papis <> [https://rvm.io/]

  1. rvm list known
  2. MRI Rubies
    [ruby-]1.8.6[-p420]
    [ruby-]1.8.7[-p358]
    [ruby-]1.8.7-head
    [ruby-]1.9.1[-p431]
    [ruby-]1.9.2-p180
    [ruby-]1.9.2-p290
    [ruby-]1.9.2-p318
    [ruby-]1.9.2[-p320]
    [ruby-]1.9.2-head
    [ruby-]1.9.3-preview1
    [ruby-]1.9.3-rc1
    [ruby-]1.9.3-p0
    [ruby-]1.9.3-p125
    [ruby-]1.9.3[-p194]
    [ruby-]1.9.3-head
    ruby-head
    ... #
    @
    then I installed ruby 1.9.3


rvm install 1.9.3

Having installed ruby 1.9.3 , I could not start redmine anymore with:

ruby script/server webrick -e production &

Somewhere I've read, that there are issues with ruby 1.9 so I
tried to downgrade ruby:

rvm uninstall 1.9.3
rvm install 1.8.7

-> I have 2 probs:
1.) I cannot upgrade again to ruby 1.9. Even if the command rvm install 1.9.3
runs succesfully, "ruby -v" has no response. I can only stop the command
with Control-c.

@
root@information:~# rvm uninstall 1.9.3
Removing /usr/local/rvm/rubies/ruby-1.9.3-p194...
root@information:~# rvm install 1.9.3
Installing Ruby from source to: /usr/local/rvm/rubies/ruby-1.9.3-p194, this may take a while depending on your cpu(s)...

ruby-1.9.3-p194 - #fetching
ruby-1.9.3-p194 - #extracted to /usr/local/rvm/src/ruby-1.9.3-p194 (already extracted)
ruby-1.9.3-p194 - #configuring
ruby-1.9.3-p194 - #compiling
ruby-1.9.3-p194 - #installing
Removing old Rubygems files...
Installing rubygems-1.8.24 for ruby-1.9.3-p194 ...
Installation of rubygems completed successfully.
ruby-1.9.3-p194 - adjusting #shebangs for (gem irb erb ri rdoc testrb rake).
ruby-1.9.3-p194 - #importing default gemsets (/usr/local/rvm/gemsets/)
Install of ruby-1.9.3-p194 - #complete
root@information:~# ruby -v
C
root@information:~#
@

2.)I cannot start ruby
@
  1. ruby script/server webrick -e production &
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/activesupport-2.3.14/lib/active_support/inflector.rb:3:in `&lt;top (required)&gt;': iconv will be deprecated in the future, use String#encode instead.
=> Booting WEBrick
=> Rails 2.3.14 application starting on http://0.0.0.0:3000
NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
Gem.source_index called from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/rails-2.3.14/lib/rails/gem_dependency.rb:21.
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/rake-0.8.7/lib/rake/alt_system.rb:32: Use RbConfig instead of obsolete and deprecated Config.
!!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again: gem install mysql.
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require': cannot load such file -- mysql (MissingSourceFile)
@

Can you give me advice to get redmine and ruby running ? Is it possible to run redmine with
ruby 1.9.3 ? If so what do I have to consider?

first of all I think I have to recover ruby-command

Please excuse my chaotic style. I really need some basic help.

Looking forward to your answer.

regards,

Ansgar

Replies (2)

RE: Update Problems - Added by Nabil Faouzi over 9 years ago

Installing rubygems-1.8.24 for ruby-1.9.3-p194

Hello, I think your rubygems version is too high for redmine and rails version is too old

2.0.0, 2.0.1 ---> ruby 1.8.7, 1.9.2, 1.9.3, jruby-1.6.7 ---> rails 3.2.3 ---> RubyGems <= 1.8

And with ruby-1.9.3 and rails 3.2.3 you can't booting webrick with this syntaxe:

ruby script/server webrick -e production &

But you should use --> ruby script/rails server webrick -e production

I've installed ruby-1.9.3 without RVM but since the source tarball, you should installed the libyaml librairies, and re install bundler and all delegate gems.

Sorry for my english :p

RE: Update Problems - Added by Ansgar Helfrich over 9 years ago

Hi Nabil,

thank you very much for your information. Meanwhile I was
able to upgrade. It all hinged on the rails-Version. So you were right ...

My problem now is that I don't how to use the "Advanced Roadmap"
in the 2.0.2 version. According to what I have read it's still
in development.

Thanks for your targeted help!

regards,

Ansgar

(1-2/2)