Redmine on Site5

Added by Imran Ali about 11 years ago

Hello guys
First let me congratulate you on this fantastic Script.

But I am having some issues installing it on Site5 so thought of reporting here to fetch some help. Firstly the versions

Redmine - SVN
Ruby - 1.8.7
Rails - 2.1.0

I am following the tutorials here on Redmine and another one on Site5.

I have been able to successfully create the DB as well as load the default data as well. It seems I have screwed up the part which involves the WEBrick server and Sym linking of the directory. I have setup the script here

I am not really sure what is the problem when you click 'public'. I have made some mods to the .htaccess file in the public as mentioned on the site5 wiki page.

Change the line
"RewriteRule ^(.*)$ dispatch.cgi [QSA,L]"
"RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]"

So what do I do from here? Help will be appreciated.

Replies (4)

RE: Redmine on Site5 - Added by Imran Ali about 11 years ago

Quick update:
It seems that the dispatch.fcgi file was not present. I have now renamed dispatch.fcgi.example to dispatch.fcgi. Is this the right way of doing it?

Anyways a new error has popped up which can be seen here

RE: Redmine on Site5 - Added by Imran Ali about 11 years ago

Another update. I am being able to run the script from the SSH command line interface

[jfusion@peony public]$ ./dispatch.fcgi
Content-Type: text/html; charset=utf-8
Set-Cookie: _session_id=595ed43d6a580d6c82de573c154777f9; path=/
Status: 200 OK
ETag: "74bb260a035ff06dd28dd2cd2169a437" 
X-Runtime: 0.16738
Content-Length: 2780
Cache-Control: private, max-age=0, must-revalidate

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">
<html xmlns="" xml:lang="en">
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="description" content="Redmine" />
<meta name="keywords" content="issue,bug,tracker" />
<link href="/stylesheets/application.css?1228070690" media="all" rel="stylesheet" type="text/css" />
<script src="/javascripts/prototype.js?1228070690" type="text/javascript"></script>
<script src="/javascripts/effects.js?1228070690" type="text/javascript"></script>
<script src="/javascripts/dragdrop.js?1228070690" type="text/javascript"></script>
<script src="/javascripts/controls.js?1228070690" type="text/javascript"></script>
<script src="/javascripts/application.js?1228070690" type="text/javascript"></script>
<link href="/stylesheets/jstoolbar.css?1228070690" media="screen" rel="stylesheet" type="text/css" />
<!--[if IE]>
    <style type="text/css">
      * html body{ width: expression( document.documentElement.clientWidth < 900 ? '900px' : '100%' ); }
      body {behavior: url(/stylesheets/;}

<!-- page specific tags -->

<link href="http://:/news?format=atom" rel="alternate" title="Redmine: Latest news" type="application/atom+xml" />
<link href="http://:/projects/activity?format=atom" rel="alternate" title="Redmine: Activity" type="application/atom+xml" />
<div id="wrapper">
<div id="top-menu">
    <div id="account">
        <ul><li><a href="/login" class="login">Sign in</a></li>
<li><a href="/account/register" class="register">Register</a></li></ul>    </div>

    <ul><li><a href="/" class="home">Home</a></li>
<li><a href="/projects" class="projects">Projects</a></li>
<li><a href="" class="help">Help</a></li></ul></div>

<div id="header">
    <div id="quick-search">
        <form action="/search" method="get">
        <a href="/search" accesskey="4">Search</a>:
        <input accesskey="f" class="small" id="q" name="q" size="20" type="text" />



    <div id="main-menu">


<div class="nosidebar" id="main">
    <div id="sidebar">


    <div id="content">


<div class="splitcontentleft">


<div class="splitcontentright">



<div id="ajax-indicator" style="display:none;"><span>Loading...</span></div>

<div id="footer">
    Powered by <a href="">Redmine</a> &copy; 2006-2008 Jean-Philippe Lang


I am now down to just seeing the effects from the browser. What is the final step guys to get this working?

RE: Redmine on Site5 - Added by Wes Billman about 11 years ago

It looks like you're trying to run in a subdirectory /code/public. You might have to setup a symlink to that directory from your Rails directory.

I'm no expert, but hopefully this helps. Judging by your SSH output you're pretty close to having this running.

RE: Redmine on Site5 - Added by Imran Ali about 11 years ago

Weirdly, although I had created the sym link earlier it wasn't working. Tried again this morning and it worked ! Thanks a lot for this great script. :D