Mail not even attempting to send (from as far as I can see)

Added by Toby Osbourn about 7 years ago

I was wondering if anyone has come across the following issues.

I have a user account set up to be emailed about everything that happens to their projects, regardless if they were the one to make the change, but they are receiving no emails.

The first thing I did was swap out SMTP for sendmail (having tested sendmail from the server and making sure it worked) this made my config file:

production:
  email_delivery:
    delivery_method: :sendmail

This didn't seem to work, I initially checked the mail.log file and it didn't seem to be getting hit at all (sending from the command line did populate the log).

The next thing I checked was production.log to see if anything rails specific was getting logged, here is a snippet of what was sent.

Started PUT "/issues/171" for 213.104.16.178 at 2013-01-03 15:08:29 +0000
Processing by IssuesController#update as HTML
  Parameters: **Snip**
  Current user: toby (id=3)
  Rendered mailer/_issue.text.erb (3.6ms)
  Rendered mailer/issue_edit.text.erb within layouts/mailer (4.6ms)
Redirected to http://redmine.prcsrv.co.uk:3000/issues/171
Completed 302 Found in 189ms (ActiveRecord: 20.1ms)

I presume when it renders mailer_/* that is for sending out emails?

Other samples I have seen online have a note in production.log talking about if the mail has sent or not.

I have tried various email addresses (as my email address and as the redmine sending email address), getting other users to edit issues, and I have tried using async_sendmail as per other suggestions I have found on this site, each time nothing seems to get logged.

Here are my Redmine settings:

Environment:
  Redmine version                          2.1.0.stable
  Ruby version                             1.9.2 (i686-linux)
  Rails version                            3.2.8
  Environment                              production
  Database adapter                         Mysql2
Redmine plugins:
  no plugin installed

Any suggestions would be gratefully received.

Thanks,
Toby

Replies (1)

RE: Mail not even attempting to send (from as far as I can see) - Added by Toby Osbourn about 7 years ago

After some more digging it looks like I didn't have actionmailer installed.

I have installed it with `gem install actionmailer` but is there something I need to do to almost recompile Redmine to see this?

(1-1/1)