Passenger && Apache2 doesn´t work anymore

Added by Nico H. over 7 years ago

Hello folks,
afert upgrading Redmine to 2.2.1 from 2.1.1 my Apache2 lists only the files and directory from the public directory (attached file).
I had some troubles with the passenger module, but I was able to fix that.

When I try to start redmine with webrick it works fine, but not with apache...
What could be wrong there and how can I fix that?

greetings

redmine.PNG (18.1 KB)

Replies (7)

RE: Passenger && Apache2 doesn´t work anymore - Added by Jan Niggemann (redmine.org team member) over 7 years ago

Please post your apache and passenger config...

RE: Passenger && Apache2 doesn´t work anymore - Added by Nico H. over 7 years ago

My apache and passenger configs are in my attachments.

RE: Passenger && Apache2 doesn´t work anymore - Added by Jan Niggemann (redmine.org team member) over 7 years ago

Does redmine work if you run it with webrick?
ruby script/rails server webrick -e production

RE: Passenger && Apache2 doesn´t work anymore - Added by Nico H. over 7 years ago

Yes, it works very fine with this way...

RE: Passenger && Apache2 doesn´t work anymore - Added by Jan Niggemann (redmine.org team member) over 7 years ago

Please try this: apachectl -t -D DUMP_MODULES|grep -i passenger
The output from that command should read

 passenger_module (shared)
Syntax OK

Does it? If not, restart apache and repeat. If the module still doesn't get loaded there's something wrong with your config...

RE: Passenger && Apache2 doesn´t work anymore - Added by Nico H. over 7 years ago

No, I got exactly the same output as you mentioned.
What could be wrong with my config?

I don´t get it...

RE: RE: Passenger && Apache2 doesn´t work anymore - Added by Jan Niggemann (redmine.org team member) over 7 years ago

Are you connecting to port 80 or 443? Try to disable MultiViews (Options –MultiViews) and try again.

Cou can also dump your config, read chapter 3.1 in this guide and try to use a subURI.

(1-7/7)