Help with upgrade on Windows

Added by Jiří Losert almost 7 years ago

Hello,
Can you advise me how to update Redmine 1.0 to a newer version? I've tried several ways, but so far I could not. I ran into an error:

"Rake aborted! no such file to lood -- bundler/setup"

I'm not experienced with ruby. Can someone please write what this error means and how to solve it?

Thank you

Replies (14)

RE: Help with upgrade on Windows - Added by Radhakrishna M almost 7 years ago

Hi, Follow these simple steps
(sublime text2 is preferable text editor)

1. Backup your redmine database

2. Download redmine recent version(preferably 2.3.0) from
http://rubyforge.org/frs/?group_id=1850

3. Goto file config-> database.yml.example
rename it to database.yml
Give your preferable database name and settings

4. Copy base configuration settings-file
config/configuration.yml into the new config directory

5. Navigate to root directory from command prompt.
run these commands
bundle install --without rmagick
rake db:create

6. then database will be created with given name.
restore your old database tables to current database

7. Run rake db:migrate

8. start server rails s

9. In browser localhost:3000

Feel free to ask further doubts

RE: Help with upgrade on Windows - Added by Jiří Losert almost 7 years ago

Thank you for your response, but did not help me.

I have a few questions:
Step 4: In version 1.1 does not in folder Redmine / config file: 'configuration.yml'. What should I do if the file is missing?
step 5: Where do I switch the root directory? Root directory downloaded new Redmine, the root directory of the installed Redmine, the system root directory (C :) or root directory Ruby in the folder: C :/ Program Files / BitNami Redmine Stack / Ruby? You need to run a command install something? Wrote me this errors: 'bundle is not recognaized as an internal or extermal command, operable program or batch file' or 'rake aborted! no such file to load -- bundler/setup'

I'm sorry but I'm a beginner, which gave the task of upgrade Redmine.

I installed redmain using BitNami Redmine 1.1.3 in windows. This version I managed run with the backup database. Localhost:81 and MySQL:3307

RE: Help with upgrade on Windows - Added by Radhakrishna M almost 7 years ago

First you need to check whether Ruby and Rails installed on your machine.

c:\users\rk> ruby -v
ruby 1.9.3p392 (2013-02-22) [i386-mingw32]

c:\users\rk> rails -v
Rails 4.0.0

c:\users\rk> bundle -v
Bundler version 1.3.4

Download and save Redmine source code in ur desired location.(for me desktop)
http://rubyforge.org/frs/?group_id=1850

Refer rails directory structure
http://www.tutorialspoint.com/ruby-on-rails/rails-directory-structure.htm

c:\users\rk\desktop\redmine-2.3.0
c:\users\rk\desktop\redmine-2.3.0>bundle install --without rmagick
c:\users\rk\desktop\redmine-2.3.0>rake db:create

Refer following link for complete step-by-step tutorial

http://www.redmine.org/projects/redmine/wiki/RedmineInstall

RE: Help with upgrade on Windows - Added by Jiří Losert almost 7 years ago

When you follow just as you so:

c:\users\jl> ruby -v
ruby 1.8.7 (2010-01-10 patchlevel 249) [i386-mingw32]

c:\users\jl> rails -v
Rails 2.3.9

c:\users\jl> bundle -v
'bundle' is not recognized as an internal or external command operable program or batch file

How do I install 'bundle'? I tried to install as follows:
'c:\users\jl>gem install bundler'

RE: Help with upgrade on Windows - Added by Radhakrishna M almost 7 years ago

Download and install Rails installer from http://railsinstaller.org/
These Packages will be installed automatically.
Ruby 1.9.3, Rails 3.2, Bundler, Git, Sqlite, Devkit

RE: Help with upgrade on Windows - Added by Jiří Losert almost 7 years ago

I installed everything as you described, but I have a problem with the step:
5. rake db:create
I did:
'c:\users\jl\desktop\redmine-2.3.0>rake db:create'
and I have problem with:
Please configure your config/database.yml first
rake aborted!
No such file or directory - C:/Users/Jiýˇ Losert/Desktop/redmine-2.3/Gemfile.lock
C:/Users/Jiří Losert/Desktop/redmine-2.3/config/boot.rb:6:in `<top (required)>'
C:/Users/Jiří Losert/Desktop/redmine-2.3/config/application.rb:1:in `<top (required)>'
C:/Users/Jiří Losert/Desktop/redmine-2.3/Rakefile:5:in `<top (required)>'
(See full trace by running task with --trace)

I set up the database as well as in version Redmine 1.1.3

RE: Help with upgrade on Windows - Added by Radhakrishna M almost 7 years ago

i've attached database.yml file. Download and paste it in redmine-2.3.0/config directory
change database name and password in the file.
Give previously created database name and mysql installation username and password.
then do rake db:create and rake db:migrate

database.yml Magnifier (909 Bytes)

RE: Help with upgrade on Windows - Added by Jiří Losert almost 7 years ago

still the same error. I've attached my database.yml file

database.yml Magnifier (904 Bytes)

RE: Help with upgrade on Windows - Added by Radhakrishna M almost 7 years ago

paste the error as it is(with command also)

RE: Help with upgrade on Windows - Added by Jiří Losert almost 7 years ago

here is error:

C:\Users\Jiří Losert\Desktop\redmine-2.3>rake db:create
Please configure your config/database.yml first
rake aborted!
No such file or directory - C:/Users/Jiýˇ Losert/Desktop/redmine-2.3/Gemfile.lock
C:/Users/Jiří Losert/Desktop/redmine-2.3/config/boot.rb:6:in `<top (required)>'
C:/Users/Jiří Losert/Desktop/redmine-2.3/config/application.rb:1:in `<top (required)>'
C:/Users/Jiří Losert/Desktop/redmine-2.3/Rakefile:5:in `<top (required)>'
(See full trace by running task with --trace)

RE: Help with upgrade on Windows - Added by Radhakrishna M almost 7 years ago

It seems to be database.yml file is not recognizing. Now, open redmine/config folder and rename database.yml.example file into database.yml and edit it.

for windows, mysql adapter is mysql2

in your gem file also include

gem 'mysql2'
C:\Users\Jiří Losert\Desktop\redmine-2.3>bundle install
C:\Users\Jiří Losert\Desktop\redmine-2.3>rake db:create

RE: Help with upgrade on Windows - Added by Jiří Losert almost 7 years ago

I provide you with access to your computer through the program "TeamViewer" would have looked to where the error is?

RE: Help with upgrade on Windows - Added by Jiří Losert almost 7 years ago

I moved the folder with Redmine and again ran the command:

C:\redmine-2.3>bundle install

I discovered another bug

C:\redmine-2.3>rake db:create
rake aborted!
126: The specified module could not be found. - C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/mysql2-0.3.11-x86-mingw32/lib/mysql2/1.9/mysql2.so
C:/redmine-2.3/config/application.rb:7:in `<top (required)>'
C:/redmine-2.3/Rakefile:5:in `<top (required)>'
(See full trace by running task with --trace)

RE: Help with upgrade on Windows - Added by Jiří Losert almost 7 years ago

I changed mysql2 to mysql and found this error:

C:\redmine-2.3>rake db:create
←[31mCould not find gem 'mysql2 (~> 2.8.1) x86-mingw32' in the gems available on this machine.←[0m
←[33mRun `bundle install` to install missing gems.←[0m

(1-14/14)