Office 365 Email Notification Settings

Added by Alex Wade over 6 years ago

Hi all,

I've tried just about every combination of email settings to authenticate with Office 365 and have had no luck. Has anybody else been able to get it to work? I get "Unrecognized Authentication Type" when sending a test email.

Here's one of my latest attempts:

default:
  email_delivery:
    delivery_method: :smtp
    smtp_settings:
      #tls: true
      enable_starttls_auto: false
      openssl_verify_mode: none
      address: "smtp.office365.com" 
      port: 587
      domain: "smtp.office365.com" 
      authentication: plain
      user_name: "redmine@mycompany.com" 
      password: "thepassword" 

Server EHLO response below.

250-XXXX.outlook.office365.com Hello [X.X.X.X]
250-SIZE 36700160
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH
250-8BITMIME
250-BINARYMIME
250 CHUNKING

Replies (2)

RE: Office 365 Email Notification Settings - Added by Bonnie O over 6 years ago

The settings below worked for me.

production:
email_delivery:
smtp_settings:
address: smtp.office365.com
port: 587
domain: smtp.office365.com
authentication: :login
user_name:
password: mypassword
enable_starttls_auto: true

RE: Office 365 Email Notification Settings - Added by Pedro Melo almost 5 years ago

These setting worked for me too, thanks a lot!

(1-2/2)