Can't send email via Redmine (Timeout error)

Added by Rafael Delanhese about 10 years ago

Hello, I have Redmine running in Apache2 installed in a Ubuntu Server v 12.10.

When I tried configure Redmine to send email, I get a timeout error.

Some important information:

1) I can successfully connect to my email server via telnet.

2) I had the same Redmine configuration running in a cloud machine and it's worked well.

3) I can send a test mail using ruby net/smtp library.

Redmine version 2.2.0.stable
Ruby version 1.9.3 (x86_64-linux)
Rails version 3.2.9
Environment production
Database adapter Mysql2
Redmine plugins:
redmine_inline_attach_screenshot 0.4.2
redmine_monitoring_controlling 0.1.1
redmine_spent_time 2.4.0

Looking at a tcp dump for the server, I find that a data package from the smtp protocol is being retransmitted until the connection

Any ideas on what is happening?

Replies (1)

RE: Can't send email via Redmine (Timeout error) - Added by hongbo yang over 9 years ago

Same error , I did not figure it out
Redmine version 2.5.1.stable
Ruby version 1.9.3-p545 (2014-02-24) [x86_64-linux]
Rails version 3.2.17
Environment production
Database adapter Mysql2
Subversion 1.8.8
Git 1.9.0
Redmine plugins:
no plugin installed

can use openssl client to telnet to smtp server, but redmine doesnot work.

How can I verity whether redmine is using correct server address ?