rake db:migrate RAILS_ENV="production" doesn't work during install step 4

Added by Micha T. over 11 years ago

Hi

The step 4 for creating the database tables doesnt work at my server.

i attached the trace file


xena@77-37-6-70:~/html/ignore.it/redmine-0.8.0$ rake db:migrate RAILS_ENV="production" --trace
(in /home/xena/html/ignore.it/redmine-0.8.0)
rake aborted!
undefined method `loaded_specs' for Gem:Module
/home/xena/html/ignore.it/redmine-0.8.0/vendor/rails/railties/lib/initializer.rb:185:in `install_gem_spec_stubs'
/home/xena/html/ignore.it/redmine-0.8.0/vendor/rails/railties/lib/initializer.rb:185:in `reject!'
/home/xena/html/ignore.it/redmine-0.8.0/vendor/rails/railties/lib/initializer.rb:185:in `install_gem_spec_stubs'
/home/xena/html/ignore.it/redmine-0.8.0/vendor/rails/railties/lib/initializer.rb:97:in `send'
/home/xena/html/ignore.it/redmine-0.8.0/vendor/rails/railties/lib/initializer.rb:97:in `run'
/home/xena/html/ignore.it/redmine-0.8.0/config/boot.rb:46:in `load_initializer'
/home/xena/html/ignore.it/redmine-0.8.0/config/boot.rb:38:in `run'
/home/xena/html/ignore.it/redmine-0.8.0/config/boot.rb:11:in `boot!'
/home/xena/html/ignore.it/redmine-0.8.0/config/boot.rb:109
/home/xena/html/ignore.it/redmine-0.8.0/Rakefile:4:in `require'
/home/xena/html/ignore.it/redmine-0.8.0/Rakefile:4
/usr/lib/ruby/1.8/rake.rb:1828:in `load'
/usr/lib/ruby/1.8/rake.rb:1828:in `load_rakefile'
/usr/lib/ruby/1.8/rake.rb:1900:in `run'
/usr/bin/rake:4

Here is my rake version
xena@77-37-6-70:~/html/ignore.it/redmine-0.8.0$ rake --version
rake, version 0.7.1

What am I doing wrong?

Regards
snudel

Replies (2)

RE: rake db:migrate RAILS_ENV="production" doesn't work during install step 4 - Added by Jean-Baptiste Barth over 11 years ago

The message tells you it cannot find some methods for "Gem:Module".
Could you precise your "rubygems" version (type "gem -v") ? I think 1.3.1 is required...

RE: rake db:migrate RAILS_ENV="production" doesn't work during install step 4 - Added by Ross Lawley over 11 years ago

gem update --system

Or, if you currently have rubygems v0.8.4 or earlier installed:

gem install rubygems-update
update_rubygems

(1-2/2)