registering an account throws a 500 error

Added by Josef Assad almost 9 years ago

Hello, I'm running a redmine server with the following specifics:

Environment:
  Redmine version                2.4.1.stable
  Ruby version                   1.9.3-p194 (2012-04-20) [x86_64-linux]
  Rails version                  3.2.15
  Environment                    production
  Database adapter               Mysql2
SCM:
  Git                            1.7.10.4
  Filesystem                     
Redmine plugins:
  redmine_auto_watch             1.0.0
  redmine_default_group          0.0.1

When a user is registering an account, upon clicking the "Send" button, a 500 error is thrown.

production.log shows the following:

Started POST "/account/register" for REDACTED_IP_ADDY at 2014-02-18 11:26:28 +0000
Processing by AccountController#register as HTML
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"REDACTED", "user"=>{"login"=>"foobar", "password"=>"[FILTERED]", "password_confir
mation"=>"[FILTERED]", "firstname"=>"foo", "lastname"=>"bar", "mail"=>"foo123@example.com", "language"=>"en-GB"}, "commit"=>"Send"}
  Current user: anonymous
Completed 500 Internal Server Error in 10.4ms

NoMethodError (undefined method `users' for nil:NilClass):
  app/controllers/account_controller.rb:136:in `register'

This only started to happen today. The only recent infrastructural change was an apt-get dist-upgrade in the underlying Debian Stable yesterday. From /var/log/apt/history.log:

Start-Date: 2014-02-17  13:21:19
Commandline: apt-get dist-upgrade
Upgrade: libc-bin:amd64 (2.13-38, 2.13-38+deb7u1), base-files:amd64 (7.1wheezy3, 7.1wheezy4), whois:amd64 (5.0.23, 5.1.1~deb7u1), apache2-mpm-prefork:amd64 (2.2.22-13, 2.2.22-13+deb7u1), apache2-utils:amd64 (2.2.22-13, 2.2.22-13+deb7u1), apache2:amd64 (2.2.22-13, 2.2.22-13+deb7u1), libyaml-0-2:amd64 (0.1.4-2+deb7u2, 0.1.4-2+deb7u3), apache2.2-common:amd64 (2.2.22-13, 2.2.22-13+deb7u1), locales:amd64 (2.13-38, 2.13-38+deb7u1), multiarch-support:amd64 (2.13-38, 2.13-38+deb7u1), apache2.2-bin:amd64 (2.2.22-13, 2.2.22-13+deb7u1), wget:amd64 (1.13.4-3, 1.13.4-3+deb7u1), file:amd64 (5.11-2, 5.11-2+deb7u1), libc6-dev:amd64 (2.13-38, 2.13-38+deb7u1), tzdata:amd64 (2013h-0wheezy1, 2013i-0wheezy1), openssl:amd64 (1.0.1e-2+deb7u3, 1.0.1e-2+deb7u4), linux-libc-dev:amd64 (3.2.51-1, 3.2.54-2), libc-dev-bin:amd64 (2.13-38, 2.13-38+deb7u1), libc6:amd64 (2.13-38, 2.13-38+deb7u1), libmagic1:amd64 (5.11-2, 5.11-2+deb7u1), libssl1.0.0:amd64 (1.0.1e-2+deb7u3, 1.0.1e-2+deb7u4)
End-Date: 2014-02-17  13:22:12

Anyone have pointers to what might be going wrong here?

Replies (1)

RE: registering an account throws a 500 error - Added by Josef Assad almost 9 years ago

Never mind, I figured it out. For the sake of future googlers:

The group that the redmine_default_group was pointing at had been changed behind my back.

(1-1/1)