Redmine Installation on CentOS 6.5

Added by Shannan Alphonso over 6 years ago

I am trying to install Redmine 2.5.1 on my server which runs on CentOS release 6.5 (Final). I have followed the instructions from http://www.redmine.org/projects/redmine/wiki/HowTo_install_Redmine_on_CentOS_5. I have used ruby 2.1.2p95 and gem 2.2.2. However, the current installation of Redmine has ended with a directory listing of the application.

Could it be an issue with the version of all the dependencies (ruby, gem and the related gems)? Is there an updated installation guide which specifies the version of the dependencies for a successful redmine installation on CentOS?

Replies (3)

RE: Redmine Installation on CentOS 6.5 - Added by Jan Niggemann (redmine.org team member) over 6 years ago

It's a fairly common error that you only see a directory listing of your public folder, use the search to find possible solutions.

RE: Redmine Installation on CentOS 6.5 - Added by Mr. DTTH over 6 years ago

Hi,

If you use Redmine 2.5.1, I recommend you install with Ruby 1.9.3-p545 stable.

You can see : Install Redmine on Centos 6.5 - 64 bit

Good bye.

RE: Redmine Installation on CentOS 6.5 - Added by Jan Niggemann (redmine.org team member) over 6 years ago

Mr. DTTH wrote:

If you use Redmine 2.5.1, I recommend you install with Ruby 1.9.3-p545 stable.

Has nothing to do with the error, but is nontheless true. Anyway, tests run OK on current trunk (at least r13184) with 2.1.2...

(1-3/3)