Can't create issue from email. (IMAP) "rake redmine:email:receive_imap" - Unable to determine target project

Added by Nanda P about 11 years ago

I am trying to create a task from email.

rake didn't give any error, but issue was not created. After enabling log in "C:\Program Files\RedMine\current\config\environments\production.rb"

# No email in production log
config.action_mailer.logger = Logger.new(File.dirname(__FILE__) + "/../../log/#{RAILS_ENV}.log")
config.action_mailer.logger.level = Logger::DEBUG

I see the following message in "C:\Program Files\RedMine\current\log\production.log"

MailHandler: missing information from Nanda Palaniswamy: Unable to determine target project

Rake command:

C:\Program Files\redmine\current>rake redmine:email:receive_imap RAILS_ENV="production" host=imap.gmail.com username=username@gmail.com password=password project=MyProject tracker=bug port=993 ssl=1 --trace
(in C:/Program Files/redmine/current)
** Invoke redmine:email:receive_imap (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute redmine:email:receive_imap

  • I have the Project & the permission (Admin)
  • I can see the email marked as Read everytime.

Could anyone help me with this?

Thanks in Advance,
Nanda

Replies (2)

RE: Can't create issue from email. (IMAP) "rake redmine:email:receive_imap" - Unable to determine target project - Added by Brennan Johnson about 11 years ago

The user who sent the email needs permission to add the issue. i.e. If userA emails userB then both userA/B need accounts on your redmine box. Redmine will say that userA created the issue.

Also, what is your identifier for the project MyProject? For some reason I was running into a similar error and rather than specify project=MyProject I configured it to point to the identifier of the project and that resolved my issue.

Let me know if that helps.

Cheers,
Brennan

RE: Can't create issue from email. (IMAP) "rake redmine:email:receive_imap" - Unable to determine target project - Added by Nanda P about 11 years ago

Brennan,

Thanks you verymuch.!

I just changed project="Project Identifire" instead of "project name"

it worked like a charm. :)

(1-2/2)