"index of /" displayed instead of homepage

Added by Alexis R over 4 years ago

Hello,

As told in title, when I try to access the root of redmine index of / is displyed instead of redmine homepage.
But if I access redmine/issues it works perfectly...

Moreover, I have a warning about a duplicated key "inodot".

I run on Ubuntu 16.04, with apache2

% ruby bin/about
/srv/redmine/redmine-3.2.0/vendor/cache/ruby/2.2.0/gems/htmlentities-4.3.1/lib/htmlentities/mappings/expanded.rb:465: warning: duplicated key at line 466 ignored: "inodot" 

sh: 1: darcs: not found
sh: 1: hg: not found
sh: 1: cvs: not found
sh: 1: bzr: not found
Environment:
  Redmine version                3.2.0.stable
  Ruby version                   2.2.3-p173 (2015-08-18) [x86_64-linux-gnu]
  Rails version                  4.2.5
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.8.13
  Git                            2.6.2
  Filesystem                     
Redmine plugins:
  redmine_default_assign         0.2.0
  redmine_issue_favicon          0.0.1

Here is my vhost, /var/www/redmine being a symbolic link to my redmine/public directory

<VirtualHost *:80>
  ServerAdmin ******@****.com
  DocumentRoot /var/www/redmine
  <Directory />
    Options +FollowSymLinks -MultiViews +Indexes
    PassengerBaseURI /
    PassengerResolveSymLinksinDocumentRoot on
    AllowOverride None
  </Directory>

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

In advance, thanks for your help!

--
Alexis

Replies (7)

RE: "index of /" displayed instead of homepage - Added by Martin Denizet (redmine.org team member) over 4 years ago

I suggest the following changes:

<VirtualHost *:80>
  ServerAdmin ******@****.com
-  DocumentRoot /var/www/redmine
+  DocumentRoot /var/www/redmine/public/
-  <Directory />
    Options +FollowSymLinks -MultiViews +Indexes
    PassengerBaseURI /
+   PassengerAppRoot /var/www/redmine  
+   PassengerPreStart http://localhost
    PassengerResolveSymLinksinDocumentRoot on
-   AllowOverride None
-  </Directory>

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

Cheers,

RE: "index of /" displayed instead of homepage - Added by Igor Rybak over 4 years ago

Have the same problem: internal site links are working, but when moving to the home page — "index of /" is displаyed.
Virtual host configuration:

<VirtualHost *:80>
        ServerAdmin admin@my.host
        ServerName project.my.host
        ServerAlias www.project.my.host
        Redirect / https://project.my.host/
</VirtualHost>

<VirtualHost *:443>
        ServerAdmin admin@my.host
        ServerName project.my.host
        ServerAlias www.project.my.host
        DocumentRoot /var/www/html/redmine/public
        Options +FollowSymLinks -MultiViews -Indexes

        RailsBaseURI /
        PassengerBaseURI /
        PassengerAppRoot /var/www/html/redmine
        PassengerPreStart http://localhost
        PassengerResolveSymLinksinDocumentRoot on

#####################   SSL settings    ###########################
        SSLEngine on
        #...other SSL options...
#####################   SSL settings    ###########################
        ErrorLog /var/log/redmine/error.log
        CustomLog /var/log/redmine/access.log combined
</VirtualHost>

Also according to this message I added line

RailsBaseURI /

but no changes.

Thanks in advance.

RE: "index of /" displayed instead of homepage - Added by Igor Rybak over 4 years ago

Just after move from server to server everything worked. After that, I installed mono server (for other virtual hosts on the server). Maybe it has made changes...

RE: "index of /" displayed instead of homepage - Added by Nebu Chad about 4 years ago

Hello !

I am having the same issue as Igor Rybak.
Server and especially Apache config is not my cup of tea, I tend to be a mess at it ...

I followed this guide after several failed installation : InstallRedmineOnDebianStableApacheMysqlPassenger

So here is my status :

gem env

RubyGems Environment:
  - RUBYGEMS VERSION: 1.8.23
  - RUBY VERSION: 1.9.3 (2012-04-20 patchlevel 194) [x86_64-linux]
  - INSTALLATION DIRECTORY: /var/lib/gems/1.9.1
  - RUBY EXECUTABLE: /usr/bin/ruby1.9.1
  - EXECUTABLE DIRECTORY: /usr/local/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /var/lib/gems/1.9.1
     - /root/.gem/ruby/1.9.1
     - /usr/share/rubygems-integration/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/

ruby bin/about

sh: darcs: command not found
sh: hg: command not found
sh: cvs: command not found
sh: bzr: command not found
Environment:
  Redmine version                3.2.0.stable
  Ruby version                   1.9.3-p194 (2012-04-20) [x86_64-linux]
  Rails version                  4.2.5
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.6.17
  Git                            1.7.10.4
  Filesystem
Redmine plugins:
  no plugin installed

/etc/apache2/sites-available/default

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined

        Include /etc/request-tracker4/apache2-modperl2.conf

        DefaultInitEnv RAILS_ENV production
        RailsBaseURI /redmine
        <Directory /var/www/redmine>
            Options -MultiViews
            PassengerBaseURI /
            PassengerAppRoot /var/www/redmine
            PassengerResolveSymLinksinDocumentRoot on
        </Directory>
</VirtualHost>

/etc/apache2/sites-available/redmine

DefaultInitEnv RAILS_ENV production
RackBaseURI /redmine
<Location /redmine>
        RailsEnv production
        RackBaseURI /redmine
        Options -MultiViews
</Location>

/etc/apache2/sites-enabled/000-default

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined

        Include /etc/request-tracker4/apache2-modperl2.conf

        DefaultInitEnv RAILS_ENV production
        RailsBaseURI /redmine
        <Directory /var/www/redmine>
            Options -MultiViews
            PassengerBaseURI /
            PassengerAppRoot /var/www/redmine
            PassengerResolveSymLinksinDocumentRoot on
        </Directory>
</VirtualHost>

/etc/apache2/mods-enabled/passenger.load

LoadModule passenger_module /var/lib/gems/1.9.1/gems/passenger-5.0.23/buildout/apache2/mod_passenger.so
   <IfModule mod_passenger.c>
     PassengerRoot /var/lib/gems/1.9.1/gems/passenger-5.0.23
     PassengerDefaultRuby /usr/bin/ruby1.9.1
   </IfModule>

/etc/apache2/mods-enabled/passenger.conf

<IfModule mod_passenger.c>
  PassengerRoot /usr
  PassengerRuby /usr/bin/ruby
PassengerUser www-data
</IfModule>

Also when I run bundle exec rails server webrick -e production I get a "Problem page loading" on http://myserver:3000

redmine is install under /opt/redmine/, ln -s /opt/redmine/public /var/www/redmine was done

Sorry if my post is messy as hell, any help will be greatly apreciated !

Nebu

RE: "index of /" displayed instead of homepage - Added by Igor Rybak about 4 years ago

The problem is still actual for me :(
Nebu Chad, did you solve this problem?

RE: "index of /" displayed instead of homepage - Added by Nebu Chad about 4 years ago

Hello Igor Rybak,

No unfortunately, I have been on holidays for 15 days and did not have time to work on it again.
But I pretty much tried everything I could before, so if no help is coming I might have to consider another solution :(

Sad because redmine looks great !

Cheers,

RE: "index of /" displayed instead of homepage - Added by Igor Rybak 4 months ago

After four years during the another Redmine installation, I encountered the same problem)) Nevertheless, I've solved the issue by installing:

sudo apt install libapache2-mod-passenger

and prescribing two settings in the Apache virtual host:
RailsEnv production
RailsBaseURI / redmine

Maybe this will help someone.

(1-7/7)