Nach Update auf 3.2.1 nur auf localhost erreichbar

Added by Hans-Jürgen Bzdak almost 5 years ago

Hallo,
ich bin neu hier und benötige hilfe.
Ich habe ein redmine Verson 2.6 auf Suse 13.2 am laufen. Alles funktioniert super ohne Probleme.
Nun habe ich ein Update auf die Version 3.2.1 gemacht, und alle Daten auf die 3.2.1 gebracht.
Mein Problem ist jetzt das die 3.2.1 nur auf dem localhost (localhost:3000) erreichbar ist, auf die IP-Adr. des
Servers (192.168.178.2:3000) reagiert die 3.2.1 nicht. Die Firewall habe ich probehalber aus geschaltet,
aber auch dann ist keine Funktion da.
In der Anleitung steht ja, das der Aufruf zum starten sich nach
"ruby bin/rails" geändert hat. Mein Startscript hat folgenden Eintrag:
start(){
cd $DIR
ruby bin/rails server -d -e production &> /dev/null
RETVAL?$?
}
$Dir "/secure/htdocs_root/redmine/redmine-3.2.1"

Ich habe mir 2 Scripte geschrieben, die einmal die 2.6 startet, das andere die 3.2.1 zum testen.
So kann ich im init.d die 2.6 oder die 3.2.1 starten.

Hat Jemand von Euch einen Tipp, warum die 3.2.1 nur auf dem localhost erreichbar ist.
Ich benötige die 172.168.178.2:3000 um das redmine mit port-forwarding im Router im Internet erreichbar
zu machen.

Über Hilfe und Tipps würde ich mich sehr freuen.
Gruß oldmodellflieger

Replies (5)

RE: Nach Update auf 3.2.1 nur auf localhost erreichbar - Added by Toshi MARUYAMA almost 5 years ago

Please post in English.

RE: Nach Update auf 3.2.1 nur auf localhost erreichbar - Added by Fabian Rose almost 5 years ago

Hans-Jürgen Bzdak wrote:

Hallo,
ich bin neu hier und benötige hilfe.
Ich habe ein redmine Verson 2.6 auf Suse 13.2 am laufen. Alles funktioniert super ohne Probleme.
Nun habe ich ein Update auf die Version 3.2.1 gemacht, und alle Daten auf die 3.2.1 gebracht.
Mein Problem ist jetzt das die 3.2.1 nur auf dem localhost (localhost:3000) erreichbar ist, auf die IP-Adr. des
Servers (192.168.178.2:3000) reagiert die 3.2.1 nicht. Die Firewall habe ich probehalber aus geschaltet,
aber auch dann ist keine Funktion da.
In der Anleitung steht ja, das der Aufruf zum starten sich nach
"ruby bin/rails" geändert hat. Mein Startscript hat folgenden Eintrag:
start(){
cd $DIR
ruby bin/rails server -d -e production &> /dev/null
RETVAL?$?
}
$Dir "/secure/htdocs_root/redmine/redmine-3.2.1"

Ich habe mir 2 Scripte geschrieben, die einmal die 2.6 startet, das andere die 3.2.1 zum testen.
So kann ich im init.d die 2.6 oder die 3.2.1 starten.

Hat Jemand von Euch einen Tipp, warum die 3.2.1 nur auf dem localhost erreichbar ist.
Ich benötige die 172.168.178.2:3000 um das redmine mit port-forwarding im Router im Internet erreichbar
zu machen.

Über Hilfe und Tipps würde ich mich sehr freuen.
Gruß oldmodellflieger

Hi

I will try to help and translate his question.

He updated his old Redmine Version 2.6 to the new 3.2.1. The update worked well without any problems.
He changed the start script (it is running on a Suse 13.2 server) to:

start(){
cd $DIR
ruby bin/rails server -d -e production &> /dev/null
RETVAL?$?
}
$Dir "/secure/htdocs_root/redmine/redmine-3.2.1"

it is working fine and Redmine 3.2.1 starts without problems.

The problem:
after the update Redmine is now only available over "http://localhost:3000" and wont work over "192.168.178.2:3000" (this is the ip of the server where Redmine is running on).

If he starts the old 2.6 Redmine it is still available over "192.168.178.2:3000".

How to make the new redmine 3.2.1 running on 192.168.178.2:3000 ?

RE: Nach Update auf 3.2.1 nur auf localhost erreichbar - Added by Hans-Jürgen Bzdak almost 5 years ago

Hello,
i add this to the well translation:
I test it without the firewall, the result is the same!

Thank you Fabian for the translation.

Best regards
oldmodellflieger

RE: Nach Update auf 3.2.1 nur auf localhost erreichbar - Added by Toshi MARUYAMA almost 5 years ago

Try -b option.

$ bundle exec rails server --help
Usage: rails server [mongrel, thin etc] [options]
    -p, --port=port                  Runs Rails on the specified port.
                                     Default: 3000
    -b, --binding=IP                 Binds Rails to the specified IP.
                                     Default: localhost
    -c, --config=file                Uses a custom rackup configuration.
    -d, --daemon                     Runs server as a Daemon.
    -u, --debugger                   Enables the debugger.
    -e, --environment=name           Specifies the environment to run this server under (test/development/production).
                                     Default: development
    -P, --pid=pid                    Specifies the PID file.
                                     Default: tmp/pids/server.pid

    -h, --help                       Shows this help message.

You should not use "rails server" for production.
You should use Web server (apache, thin, etc.) instead.

RE: Nach Update auf 3.2.1 nur auf localhost erreichbar - Added by Hans-Jürgen Bzdak almost 5 years ago

Hello,
thank you very much, this was the right tip. It runs now from IP-Adr. Soon i will change the redmine to a
Webserver. Thank you for this tip.

Best regards
oldmodellflieger

(1-5/5)