Issue Edit/Submit very slow

Added by John Simmons over 3 years ago

  Redmine version                3.3.2.stable.16427
  Ruby version                   2.0.0-p648 (2015-12-16) [x86_64-linux-gnu]
  Rails version        
  Environment                    production
  Database adapter               Mysql2
  Subversion                     1.8.8
  Git                            1.9.1
Redmine plugins:
  no plugin installed
  Ubuntu 14.04 Server

When I go to update an issue, it takes anywhere from 5 to 20 seconds to update (show the next view of "success"). This happens for every user, and it happened while I was on version 3.2 as well. When googling this, the first thing I came across was SMTP settings, and I thought for sure that would be it because it was close to the same time that we moved to office365 email settings that the problem appeared. I'm not 100% sure that the issue happened at the same time as the change, but it could have. But, after changing to async_smtp, there was no speed change.

I believe the SMTP settings are correct for async, since emails are being sent successfully. I'll post them here anyway, just in case it's still not actually sending using the async method.

    delivery_method: :async_smtp
      address: "" 
      port: '587'
      domain: "" 
      authentication: :login
      user_name: "" 
      password: "MyPassword" 
      enable_starttls_auto: true

I haven't seen anything odd in /var/log/apache2/redmine.access.log, or redmine.error.log. Is there anywhere else that I can look to see what's causing this delay? Any help is appreciated.

Replies (2)

RE: Issue Edit/Submit very slow - Added by Anonymous over 3 years ago


Sounded like async_smtp, but you identified already this. You could open a terminal console, start linux load-monitor "top" and observe system load in parallel to updating issues. Maybe this gives you a hint.



RE: Issue Edit/Submit very slow - Added by John Simmons over 3 years ago

Thanks. It ended up being an error on my part. I must have typed something incorrectly into the config file. I deleted the entire configuration file, and recreated it with the same configuration shown above, and it worked, and increased the speed greatly. I guess I mistyped something originally.