Wrong rails version after svn update

Added by Erik Dannenberg almost 11 years ago

hi,

i just foolishy did a svn update on our redmine, ofcourse it now refuses to start with:

=> Booting WEBrick...
/Data/web/redmine/config/../vendor/plugins/engines/boot.rb:4: This version of the engines plugin requires Rails 2.2.0 or later! (RuntimeError)
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from /Data/web/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require'
from /Data/web/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:355:in `new_constants_in'
from /Data/web/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require'
from /Data/web/redmine/config/environment.rb:15
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from /Data/web/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require'
from /Data/web/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:355:in `new_constants_in'
from /Data/web/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require'
from /Data/web/redmine/vendor/rails/railties/lib/commands/servers/webrick.rb:59
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from /Data/web/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require'
from /Data/web/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:355:in `new_constants_in'
from /Data/web/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in `require'
from /Data/web/redmine/vendor/rails/railties/lib/commands/server.rb:39
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from /Data/web/redmine/script/server:3
Starting Redmine on Ruby

i updated rails via gem update but nothing changed.

#rails -v
Rails 2.3.2

downgrading from rails 2.3.2 to 2.2.2 didnt help either.

from what i gathered it might be that there is a rails version already in vendor/ dir, which prolly is the outdated one redmine is trying to use.

any help would appreciated..

Replies (1)

RE: Wrong rails version after svn update - Added by Erik Dannenberg almost 11 years ago

ok fixed it:
removed vendor/rails, upgraded ruby-gems to 1.3.1. and added config.action_controller.session to config/environment.rb

use the following to update ruby-gems on debian/ubuntu:
sudo gem install rubygems-update
sudo update_rubygems

(1-1/1)