SVN Problem

Added by Christian K about 16 years ago

Hi All.

First off, I would like to thank you for making this amazing product. It's made my team's lives so much easier.

However, we have run into some problems with repository. No matter what we do, we can't mange to get it to work. It simply says "Entry and/or revision doesn't exist in the repository."

We have tried messing with the setting and switching between http://, svn://, and file:/// urls, and nothing works. They all yield the same result. We have also tried using different username and password combinations, yet nothing has changed. The repository is very important to our team and we are deeply in need of it.

Here is some of our server information:
SVN: 1.4.6
Redmine: 0.6.4
Apache: 2.0.63
Ruby: 1.8.6
MySQL: 5.0.45-community

Could my RoR version be blame? I noticed in the readme it said 1.2.6 or 2.0.2, but everything installed fine so I just wrote it off. Anywho, thanks for taking the time to read my post. It is very much appreciated. :)

Replies (3)

RE: SVN Problem - Added by Thomas Lecavelier about 16 years ago

hi Christian,

Even if you hadn't written here your rails version, there's a way to verify if it comes from there: just freeze a RoR2.0.2 in your redmine instance, running from your redmine root directory:

rake rails:freeze:edge TAG=rel_2-0-2

rake will download a whole copy of Rails v2.0.2 in your vendor/ directory. This copy will not interfer with your other rails applications. If you meet problem with this 2.0.2, just run "rake rails:unfreeze" to undo this copy.

Have a nice day.

RE: SVN Problem - Added by Christian K about 16 years ago


First off, thank you for your reply. I was under the impression my Ruby version was also my RoR version, which isn't the case. Sorry about that. I was able to find the correct version number and it is in fact 2.0.2.

Do you have any other thoughts as to why we might be having this problem?

Thank you for you help again,

RE: SVN Problem - Added by Thomas Lecavelier about 16 years ago

Christian, check that the subversion target is a valid repository (and not a working copy), then that the process running redmine have rights to read it and navigate trhough its directories. Otherwise, you can switch your log to debug level trying to get a deeper understanding of your problem (config/environnement.rb uncomment the logger.level line)