Installation Error: Segmentation Fault

Added by John Clifford over 13 years ago

Ruby implementation and version:
- Rails version (rails --version): 2.3.2
- Operating system : Windows XP SP2
- Database used, and its version : MySQL 5.1.33-community (on another box - Win Server 2K3)
- Ruby-aware server used: Webrick

firstly, I'm new to RoR, and see that the http://www.redmine.org/wiki/redmine/RedmineInstall says that current SVN trunk requires Rails 2.2.2, I appear to have 2.3.2 (despite a "gem install rails -v=2.2.2")

Actual error: When I attempt to "rake db:migrate RAILS_ENV="production"" I get a nasty SEGMENTATION FAULT (error posted at http://pastie.org/453124)

Ends with:
...
c:/ruby/bin/rake:16
c:/ruby/bin/rake:16: [BUG] Segmentation fault
ruby 1.8.6 (2007-09-24) [i386-mswin32]

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Any guidance appreciated :)

Replies (2)

RE: Installation Error: Segmentation Fault - Added by Mischa The Evil over 13 years ago

John Clifford wrote:

Ruby implementation and version:
- Rails version (rails --version): 2.3.2
[...]

[...] see that the http://www.redmine.org/wiki/redmine/RedmineInstall says that current SVN trunk requires Rails 2.2.2, I appear to have 2.3.2 (despite a "gem install rails -v=2.2.2")

Actual error: When I attempt to "rake db:migrate RAILS_ENV="production"" I get a nasty SEGMENTATION FAULT (error posted at http://pastie.org/453124)

Any guidance appreciated :)

Ok, some comments:
  • Looking at your pastie you've currenly checked-out the 0.8-stable branch instead of the trunk.
  • 0.8-stable requires/is compatible only with Rails 2.1.2 instead of 2.2.2 or 2.3.2 (see RedmineInstall).
  • The above leads to the conclusion that you need to have Rails 2.1.2 installed too (gem install rails -v=2.1.2) for running 0.8-stable.
  • Make a decision about what version of Redmine you want to use (see CheckingoutRedmine) ;-)
  • Make sure that source:trunk/config/environment.rb#L8 is configured correctly according to the installed Redmine version in relation to the Rails version.

HTH... Let me know how it goes...

Regards,

Mischa.

RE: Installation Error: Segmentation Fault - Added by Nanda P over 13 years ago

I faced the same issue, The issue was fixed by replacing MySQL 5.1 with MySQL 5.0

Check : http://www.redmine.org/boards/2/topics/4392#message-4479

Hope it helps

(1-2/2)