[LDAP] can't create new authentication mode

Added by Petr Vosa 12 months ago


iam trying to link redmine with my Active Directory server.

Following the guide ([[http://www.redmine.org/projects/redmine/wiki/RedmineLDAP]]) i filled the form.
But when i try to Create it, i get this error:

Internal error
An error occurred on the page you were trying to access.
If you continue to experience problems please contact your Redmine administrator for assistance.

If you are the Redmine administrator, check your log files for details about the error.

And the log says this (some data replaced with x):

Started POST "/redmine/auth_sources" for xxx
Processing by AuthSourcesController#create as HTML
Parameters: {"utf8"=>"✓", "-xxxxxxxxxxxxx-"}, "commit"=>"Create"}
Current user: xxx (id=-xx-)
Completed 500 Internal Server Error in 44ms (ActiveRecord: 5.3ms)

NoMethodError (undefined method `verify_peer=' for #<AuthSourceLdap:0x00557d35bf8f08>):

app/models/auth_source_ldap.rb:133:in `ldap_mode='
lib/redmine/safe_attributes.rb:88:in `safe_attributes='
app/controllers/auth_sources_controller.rb:96:in `build_new_auth_source'
lib/redmine/sudo_mode.rb:63:in `sudo_mode'

I have connectivity to my LDAP server.
I tried many different variations when filling the form, in case i typed in something incorrectly, but still getting the same error.
What could be causing this error, please?