Can't install redmine_ckeditor plugin, get permission errors

Added by Ted Fines 2 months ago

System Info:
Redmine version 4.0.3.stable
Ruby version 2.3.5-p376
Rails version 5.2.2.1
OS: Debian 9.9
DB: MariaDB 10.1.38

The author of the plugin has instructions here:
https://github.com/a-ono/redmine_ckeditor

1. Download the zip file into the plugins directory (make sure the name is redmine_ckeditor)
2. In the redmine root directory (this is "/var/www/redmine" I think?) run "bundle install --without development test"

When I try #2 as root, I get a warning that I shouldn't run the command as root, so I don't.

What user should I run it as? I can't run it as www-data (the webserver user) unless I change /etc/password so it has a shell. But even then it still didn't work because it couldn't write to "/var/www/redmine/.bundle/config" which is owned by root.

So I changed the 'config' file so www-data owns it but I get another error:
/usr/local/rbenv/versions/2.3.5/lib/ruby/gems/2.3.0/cache/budnler/git/rich-50774502e3893a04be60fd735c8f2c96bc68acea: Permission denied

I don't want to randomly go down the permissions rabbit hole. So before I go changing all the permissions on everything I thought I'd ask for some guidance. How do I properly install this plugin? What user do I run the command as, and how do I set that up?

Thanks!