incompatible character encodings: UTF-8 and CP850

Added by Jej Jerome about 1 month ago

Hello,

I have an issue at first use of redmine.
I've installed Redmine 4.1.1 on Windows with an SQL Server database.
Once I add an LDAP connection, I have an error 500.

Started GET "/auth_sources" for 127.0.0.1 at 2020-09-18 09:58:09 +0200
Processing by AuthSourcesController#index as HTML
  Current user: admin (id=1)
  Rendering auth_sources/index.html.erb within layouts/admin
  Rendered auth_sources/index.html.erb within layouts/admin (5.2ms)
  Rendered admin/_menu.html.erb (3.1ms)
  Rendering layouts/base.html.erb
  Rendered layouts/base.html.erb (23.0ms)
Completed 500 Internal Server Error in 57ms (ActiveRecord: 17.0ms)

ActionView::Template::Error (incompatible character encodings: UTF-8 and CP850):
    107:     <div id="sidebar">
    108:         <%= yield :sidebar %>
    109:         <%= view_layouts_base_sidebar_hook_response %>
    110:     </div>
    111: 
    112:     <div id="content">
    113:         <%= render_flash_messages %>

Each time, I delete database and reinstall it but I still have the issue.
I've tried encoding utf8, CP850 and without encoding line in database.yaml.
I have this error each time I set up my LDAP, I had it when I set French asdefault language.

I have no idea how to solve this issue. Thanks for your help.

Replies (2)

RE: incompatible character encodings: UTF-8 and CP850 - Added by Liane Hampe about 1 month ago

Where did you set French as default language, in your LDAP or in Redmine?

RE: incompatible character encodings: UTF-8 and CP850 - Added by Jej Jerome about 1 month ago

In Redmine. I don't know how the LDAP is configured.

Now my installation work because I used "back" button and logged out.

(1-2/2)