How to upgrade Bitnami Redmine 1.4.1 Stack and to which version to support TLS 1.2 and above?

Added by Rad V 4 months ago

We are utilizing the Bitnami Stack Redmine version 1.4.1 which is running on Windows 2016, and we would like to upgrade it to appropriate version of Bitnami Redmine Stack Package which in turn will support TLS 1.2 because the complied apache 2.4( and OpenSSL 1.1.1 (openssl.exe) comes with the Bitnami package. So could you please share which is the best version to download and migrate the data from Redmine 1.4.1? Best way to upgrade is also appreciated. Please share your valuable comments.

Bitname Redmine 1.4.1 Stack Components:
- Redmine 1.4.1
- Apache 2.2.22
- ImageMagick 6.5.6-8-Q8
- MySQL 5.0.83
- Subversion 1.7.4
- Ruby 1.8.7-p358-i386-mingw32
- Rails 2.3.14
- RubyGems 1.6.2


Replies (1)

RE: How to upgrade Bitnami Redmine 1.4.1 Stack and to which version to support TLS 1.2 and above? - Added by Liane Hampe 4 months ago

Hi Rad,

This is quite a lot to do for you. Please be prepared for some error messages you will face and need to handle. From my experience I would say you cannot avoid them.

I would recommend to do the Redmine upgrade in the following steps:

  1. from 1.4.1 to 1.4.z where z is the latest patch
  2. from 1.4.y to 1.y where y is the latest minor version
  3. from 1.y to 2.y
  4. from 2.y to 3.y
  5. from 3.y to 4.y.z

Ruby and RubyGems

Along with these Redmine upgrades you need to upgrade Ruby. RubyGems does not need to be installed explicitly but I do not know from which Ruby version ongoing this is true.


You can remove Rails 2.3.14 if it is installed independently of Redmine. Redmine has the required Rails version defined in its Gemfile.


I would upgrade it to the latest version but ignore it when running bundler for Redmine until you arrive the latest version.


The required Bundler version should also be determined in the Redmine Gemfile when I remember right. You can check that. Otherwise upgrade along with Redmine.


Your current MySql is also outdated. Maybe start the first upgrade with the lowest version to be accepted by Redmine now or check what was the highest version of MySQL recommended for your current Redmine version and start with that.

Subversion and Apache

Both, Subversion and Apache, should not be more stable with Redmine. Therefore, I would ignore them in as long as possible and care for them after the Redmine upgrade is done.

Current supported versions of Redmine requirements

You can read here about what Ruby, MySQL, Rails is required

For older versions of Redmine you can try to get the same information via the wiki page history.


In case you run Redmine with plugins, you should move them out as long as you upgrade. Moreover, you would need suitable plugin versions at the end.

Redmine upgrade process

Here you can read what to do in a single upgrade process:

You need to repeat it as suggested above until you end at the current version.

Good Luck!