REST API authentication failed

Added by Vihren Todorov 21 days ago

We would like to authenticate Redmine against zapier. But there is an error authentication failed.

I used https://DNSname.com/remdine and https://DNSname.com but it did not work.

API web serivces is enabled under Settings - API

Am I not using the correct syntax under the address box ?

3.PNG (29.3 KB)

4.PNG (21 KB)

2.PNG (5.49 KB)

1.PNG (25.2 KB)

Replies (7)

RE: REST API authentication failed - Added by Liane Hampe 21 days ago

Hello Vihren,

Did you really enter your api key into the text field of the form below?

The api key a a very long sequence of numbers and letters.

Best Regards,

Liane

RE: REST API authentication failed - Added by Vihren Todorov 21 days ago

Hi Liane,

yes I did.. API token found under My Account section when you click the 'show' button
Also the user is admin.
Tried with a local account (admin) and ldap account (admin).
No luck

RE: REST API authentication failed - Added by Liane Hampe 21 days ago

Okay, assuming the URL you entered was without typo, we cannot help here.

What ever Zapier tries to do with these two data is a black box for the Redmine Community.

One last idea: Please have a look at the production.log of your Redmine instance. Maybe there is something useful ...

RE: REST API authentication failed - Added by Vihren Todorov 21 days ago

This is the output of the log but no new lines are generated when the connection is attempted.

/redmine-4.0.3# tail -f log/production.log
Rendered users/_preferences.html.erb (152.0ms)
Rendered my/_sidebar.html.erb (7.0ms)
Rendered my/account.html.erb within layouts/base (213.7ms)
Completed 200 OK in 242ms (Views: 215.7ms | ActiveRecord: 19.3ms)
Started GET "/redmine/my/api_key" for [Mask IP] at 2020-09-29 09:22:30 +0200
Processing by MyController#show_api_key as JS
Current user: [MASK] (id=[MASK])
Rendering my/show_api_key.js.erb
Rendered my/show_api_key.js.erb (3.4ms)
Completed 200 OK in 23ms (Views: 11.0ms | ActiveRecord: 1.7ms)

RE: REST API authentication failed - Added by Liane Hampe 21 days ago

When there is no output concerning your authentication attempts via Zapier then Redmine did not get any request, apparently. The process seems to fail before any authentication in Redmine takes place.

You can try to access the Redmine API via cURL. If it works, you know that the problem is more likely to be on the Zapier side. If not, please let us know by sending the command you tried and the retrieved log messages again, in hope for more meaningful information.

Best Reagards,

Liane

RE: REST API authentication failed - Added by Vihren Todorov 20 days ago

this works in putty

Capture.PNG (23.3 KB)

(1-7/7)