REDMINE 4.1.1 - NoMethodError

Added by Gleb Efimov almost 2 years ago

Good day everyone.
I'm a pretty weak newbie, but it so happened that I need to install Redmine 4.1.1 on MS SQL SERVER 2018, running on Win 10.
I' m using the following:

ruby 2.7.2p137 (2020-10-01 revision 5445e04352) [x64-mingw32]
Rails 6.1.3
rake 13.0.3
concurrent-ruby 1.1.8
i18n 1.8.9
minitest 5.14.4
tzinfo 2.0.4
zeitwerk 2.4.2
activesupport 6.1.3
builder 3.2.4
erubi 1.10.0
racc 1.5.2
nokogiri 1.11.1 (x64-mingw32)
rails-dom-testing 2.0.3
crass 1.0.6
loofah 2.9.0
rails-html-sanitizer 1.3.0
actionview 6.1.3
rack 2.2.3
rack-test 1.1.0
actionpack 6.1.3
nio4r 2.5.5
websocket-extensions 0.1.5
websocket-driver 0.7.3
actioncable 6.1.3
globalid 0.4.2
activejob 6.1.3
activemodel 6.1.3
activerecord 6.1.3
mimemagic 0.3.5
marcel 0.3.3
activestorage 6.1.3
mini_mime 1.0.2
mail 2.7.1
actionmailbox 6.1.3
actionmailer 6.1.3
actiontext 6.1.3
activerecord-sqlserver-adapter 2.3.8
msgpack 1.4.2
bootsnap 1.7.2
bundler 2.1.4
ffi 1.14.2 (x64-mingw32)
jbuilder 2.11.2
method_source 1.0.0
puma 5.2.1
rack-proxy 0.6.5
thor 1.1.0
railties 6.1.3
sprockets 4.0.2
sprockets-rails 3.2.2
rails 6.1.3
sassc 2.4.0 (x64-mingw32)
tilt 2.0.10
sassc-rails 2.1.2
sass-rails 6.0.0
semantic_range 2.3.1
sqlite3 1.4.2
tiny_tds 2.1.3 (x64-mingw32)
turbolinks-source 5.2.0
turbolinks 5.2.1
tzinfo-data 1.2021.1
webpacker 5.2.1

My problem is that every time I try to execute bundle exec rake generate_secret_token procedure, or bundle exec rake db: migrate
I get an error:

rake aborted!
NoMethodError: undefined method `alias_method_chain' for #<Class:ActiveRecord::Base>
Did you mean? alias_method
C:/REDMINEapp/blog/config/application.rb:7:in `<top (required)>'
C:/REDMINEapp/blog/Rakefile:4:in `require_relative'
C:/REDMINEapp/blog/Rakefile:4:in `<top (required)>'
(See full trace by running task with --trace)

As far as I understand, `alias_method_chain' shoud not be existed in Ruby versions above 3m but no matter how hard I tried to locate and get rid of this line, I couldn't find it. Honestly, I'm out of options.
Any help or advice would be greatly appreciated.

Replies (1)

RE: REDMINE 4.1.1 - NoMethodError - Added by Go MAEDA almost 2 years ago

Probably some plugin that does not support Redmine 4.1 causes the error. Please try again after uninstalling all plugins.

(1-1/1)