Multiple plugins not working properly (NoMethodError)

Added by Marvin Wendland 2 months ago

Since we have upgraded to redmine version 4.2.3, every plugin we have tried to install has not worked properly.
Installing the plugin and running the migrations with "RAILS_ENV=production bundle exec rake redmine:plugins:migrate" works without problems, but when trying to access the plugins functions in redmine, we get an error in the form of:

"NoMethodError (undefined method 'MethodName' for nil:NilClass)"

To our understanding, this means that the object for which the methods are called are not passed properly.
For some plugins we managed to fix this by altering the controller of the plugin slightly, but since this happens for every plugin we install, there seems to be a problem with our redmine installation that we cannot locate with our limited knowledge. Any idea what might cause this?

Plugins where this has happened:
Checklists: https://www.redmine.org/plugins/redmine_checklists
Agile: https://www.redmine.org/plugins/redmine_agile
Issue templates: https://www.redmine.org/plugins/redmine_issue_templates
Tags: https://www.redmine.org/plugins/redmineup_tags

Ruby: ruby 2.6.4p104 (2019-08-28 revision 67798) [x86_64-linux]
Rails: Rails 5.2.6
OS: Ubuntu 18.04.6 LTS
DB: 10.3.8-MariaDB-log

example.png - Example of the error that plugins produce (17 KB)