Project

General

Profile

Please help me to setup email configuration on Bitnami Redmine.

Added by Bui Chau about 1 year ago

Hello everyone.
Good day.

I am newbie with Redmine. I installed the Redmine (bitnami version) on a virtual machine and can do almost tasks with it.
But I cannot to configure the email notification.
I always get the error when I Send a test email, something like this:

An error occurred while sending mail (Timeout to open TCP connection to smtp.gmail.com:587 (exceeds 30 seconds))

Can you help me to check and setup it?

Thank you very much!


Replies (6)

RE: Please help me to setup email configuration on Bitnami Redmine. - Added by Joan J about 1 year ago

This error probably means that there's no connection from your VM to google, you probably will have to set some firewall rules

RE: Please help me to setup email configuration on Bitnami Redmine. - Added by Bui Chau about 1 year ago

Dear Joan J.
Thank you very much.
I will check the connection now.

RE: Please help me to setup email configuration on Bitnami Redmine. - Added by Bui Chau 12 months ago

Dear everyone,
good day.

I would like to update I can setup the email notification.
But not Gmail, it's Office 365 infra.
This is my code:


# default configuration options for all environments
default:
  # Outgoing emails configuration
  # See the examples below and the Rails guide for more configuration options:
  # http://guides.rubyonrails.org/action_mailer_basics.html#action-mailer-configuration
  email_delivery:
  #  delivery_method: :smtp
    smtp_settings:

      address: smtp.office365.com
      port: 587
      domain: smtp.office365.com
      authentication: :login
      user_name: xxxx@nitori.com.my
      password: xxxxxxxxxxx
      enable_starttls_auto: true

RE: Please help me to setup email configuration on Bitnami Redmine. - Added by Brian BB 12 months ago

Maybe this


default:
  email_delivery:
    delivery_method: :smtp
    smtp_settings:
      address: smtp.office365.com
      port: 587
      domain: nitori.com.my    #  domain should not be the same as address?.
      authentication: :login
      user_name: xxxx@nitori.com.my
      password: xxxxxxxxxxx
      enable_starttls_auto: true
    (1-6/6)