How to force redmine to build https urls (not http)?

Added by Michael Haren over 10 years ago

I am attempting to run Redmine through an Apache reverse proxy. Mongrel serves plain-text pages which Apache protects with SSL and serves to my users. The problem is that various links and redirects within Redmine send users to http:// instead of https:// .

The settings on the admin page are configured for https but this doesn't seem to help. I also added this line to environment.rb to solve a relative root problem (that fixed it, but not the https problem):

ActionController::AbstractRequest.relative_url_root = "/r/" 

How can I force Redmine to always use https?

Replies (2)

(1-2/2)