!!!!Perfomance issue when using with remote SVN!!!!!

Added by Đức Tạ over 10 years ago

localhost:8888 -> 17 KB -> 8.89s

Im currently running on Mongrel (5process) and nginx (5process), its abit overkill for this, but just for a test...

The loading time when i click the Repository tab is 8.89s, i really dont know why it take this long. can someone suggest me a solution for this?

My OS is windows. Running on NGINX make SVN functional, but there are some issue when nginx proxy stop and hang while all my other Mongrel work just fine. Can some one suggest?

2nd question:
I tried running on IIS with FCGI (it's fast, thanks god), but however, the Repository SVN is not working. When i click the repository tab, i can't see any file from my Repo...

Can some one give me a solution?

Thank you very much!

ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]
Rails 2.1.2
Installed CYGWIN but never use
Windows7
mysql Ver 14.14 Distrib 5.4.2-beta, for Win32 (ia32)
Running on Mongrel(5) + NGINX
Please take a look at my issue with IIS + FCGI

About your application's environment
Ruby version 1.8.6 (i386-mswin32)
RubyGems version 1.3.1
Rails version 2.1.2
Active Record version 2.1.2
Action Pack version 2.1.2
Active Resource version 2.1.2
Action Mailer version 2.1.2
Active Support version 2.1.2
Application root D:/Duc/Work/D-CMS/redmine-0.8
Environment development
Database adapter mysql
Database schema version 101

Replies (4)

RE: !!!!Perfomance issue when using with remote SVN!!!!! - Added by Eric Davis over 10 years ago

Đức Tạ wrote:

localhost:8888 -> 17 KB -> 8.89s

Im currently running on Mongrel (5process) and nginx (5process), its abit overkill for this, but just for a test...

The loading time when i click the Repository tab is 8.89s, i really dont know why it take this long. can someone suggest me a solution for this?

That's because Redmine has to connect to your SVN server to check for new commits. See this FAQ for details about how to run this in another process.

Eric Davis

RE: !!!!Perfomance issue when using with remote SVN!!!!! - Added by Đức Tạ over 10 years ago

yes, i setted up to run every 10 min on background before, but how should i turn off the automatic fetching when click the repository tab?

RE: !!!!Perfomance issue when using with remote SVN!!!!! - Added by Eric Davis over 10 years ago

Look for the Autofetch Commits option in Administration > Settings. RedmineSettings

Eric Davis

(1-4/4)