Mercurial with network shares

Added by Matthieu BIENVENÜE about 12 years ago

Hello all,

I've made an install of Redmine using the bitnami stack on Windows XP Pro. The installation succeed and it works fine.
I'm using mercurial repositories. It works fine when repositories are located on local hard drive (e.g. in My docs). There is no problem and I'm able to browse them.

But my production repositories are stored on a network share. The share is mounted as a network drive (r:\).
When I'm trying to give the directory path on the share (i.e.: R:\Tmp_Tests\MercurialTest2\, redmine fails to browse it:

"The entry or revision was not found in the repository."

And nothing more is displayed. In log file, there is a 500 error: internal server error.

What do you thing about that? Any idea or workaround to solve the problem?

Thank you!

Kind regards

Matthieu

Replies (2)

RE: Mercurial with network shares - Added by Steve Steiner about 12 years ago

Same issue -- any resolution?

Thanks,

S

RE: Mercurial with network shares - Added by Ted Lilley almost 12 years ago

Most likely this is because network shares aren't visible between user sessions, and the Redmine service is likely running as the local system account.

I've tried to set up shared drive access for Redmine as well, with poor success. I was able to get drive mapping to work, but it seems to disconnect itself after a while and requires manual intervention to get reconnected.

There are two alternatives:

  1. run the redmine server as a user that you can log in as and set up the share
  2. set up a share as the local system account

I haven't tried the first option, so I don't really know if it works.

For the second option, it can be pretty tricky to log in as the system account in order to run the appropriate commands. I did this a while back so I don't have the exact documentation, but it goes something like this:

  1. Grab the psexec utility (I just get the whole Sysinternals Suite) from www.sysinternals.com
  2. Run psexec with the -s option to tell it to use the system account, telling it to run cmd.exe
  3. With the new system account command window that pops up, use the net share commands to mount the drive in the appropriate place
  4. Restart the Redmine service

Like I said, that's a rough of what I did, the steps may vary a bit. I also have had to reconnect the drive periodically for some unknown reason.

If anybody has a better way, I'm interested.

(1-2/2)